Bug 1291088 - Only grey background with mouse cursor pop-ups
Only grey background with mouse cursor pop-ups
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
ppc64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-13 11:53 EST by Lukas Doktor
Modified: 2016-01-29 15:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 15:39:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Avocado-vt test resutls with the bug (1.98 MB, application/zip)
2015-12-13 11:53 EST, Lukas Doktor
no flags Details

  None (edit)
Description Lukas Doktor 2015-12-13 11:53:46 EST
Created attachment 1105363 [details]
Avocado-vt test resutls with the bug

Description of problem:
When installing RHEL7 from ISO on ppc64 guest on ppc64, the machine boots properly but when the anaconda switches to graphical mode it only displays grey background with mouse cursor and hangs. It proceeds with installation (using kickstart) on the background, but the UI is not displayed. This occurred couple of times in past 6 months using stock/custom qemus on various combinations of ppc64 BE/LE, unfortunately the results were destroyed. Now it reoccurred so I'm attaching the results.

Version-Release number of selected component (if applicable):
RHEL-7.2-20151015.0-Server-ppc64le-dvd1.iso (but I saw it previously, so multiple versions and BE/LE architectures might apply to)
kernel-3.10.0-327.el7.ppc64le
custom built qemu-2.5 (but was spotted on stock qemu too, only the results were not preserved)

How reproducible:
From time to time

Steps to Reproduce:
1. Run unattended install on ppc64 using "-vga std" and "-vnc"
2. Watch the display until you see either graphical install or this bug

Actual results:
Grey background with cursor mouse

Expected results:
Anaconda graphical UI

Additional info:
screendumps: https://kvmqe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/RHELSA-devels/view/results/job/rhelsa-wup-2.5-ppc64le-on-ppc64le.run/4/artifact/latest/test-results/io-github-autotest-qemu.unattended_install.cdrom.extra_cdrom_ks.default_install.aio_threads/screendumps_avocado-vt-vm1_40453_iter0/

results from failed test: https://kvmqe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/RHELSA-devels/view/results/job/rhelsa-wup-2.5-ppc64le-on-ppc64le.run/4/testReport/junit/(root)/VirtTest/io_github_autotest_qemu_unattended_install_cdrom_extra_cdrom_ks_default_install_aio_threads/
Comment 2 David Shea 2015-12-14 07:39:35 EST
Please attach the logs from /tmp to this bug as individual, text/plain attachments.
Comment 3 Lukas Doktor 2016-01-04 08:55:53 EST
There are 936 files in results. Do you really want me to attach them one by one in text/plain form?
Comment 4 David Shea 2016-01-04 09:48:12 EST
(In reply to Lukas Doktor from comment #3)
> There are 936 files in results. Do you really want me to attach them one by
> one in text/plain form?

anaconda.log, storage.log, packaging.log and program.log are the ones created by anaconda. There are may also be several dnf.*.log files.
Comment 5 David Shea 2016-01-04 09:49:57 EST
(In reply to David Shea from comment #4)
> There are may also be several dnf.*.log files.

Except that this is RHEL, so of course there will not be dnf log files. The other four log files should be there, though.
Comment 6 Lukas Doktor 2016-01-23 11:44:53 EST
Well I tried to reproduce it on RHEL.7.3 host with new and the old guest install DVD to get the provided files, but it just worked well.
Comment 7 David Cantrell 2016-01-29 15:39:58 EST
Closing per comment #6. (and assuming you mean RHEL 7.2)

Note You need to log in before you can comment on or make changes to this bug.