This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1291144 - [RHEVM]: Removing a file-typed data domain leaves zero byte size file __DIRECT_IO_TEST__
[RHEVM]: Removing a file-typed data domain leaves zero byte size file __DIREC...
Status: CLOSED WONTFIX
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
---
x86_64 Linux
unspecified Severity medium (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Maor
Aharon Canan
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 01:34 EST by Byreddy
Modified: 2016-03-13 11:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-13 11:23:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tnisan: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Byreddy 2015-12-14 01:34:37 EST
Description of problem:
=======================
Removed the Data domain created using the RHGS nodes AND Observed one zero size file in the RHGS bricks after removing the data domain.


On node-1:
~~~~~~~~~
[root@dhcp a0]# ls -lt
total 0
-rwxr-xr-x. 2 vdsm kvm 0 Dec 11 03:53 __DIRECT_IO_TEST__
[root@dhcp a0]# 

On Node-2:
~~~~~~~~~~
[root@dhcp a1]# ls -lt
total 0
-rwxr-xr-x. 2 vdsm kvm 0 Dec 11 03:53 __DIRECT_IO_TEST__
[root@dhcp a1]# 


Version-Release number of selected component (if applicable):
=============================================================
Red Hat Enterprise Virtualization Manager Version: 3.5.6.2-0.1.el6ev


How reproducible:
=================
One time observed


Steps to Reproduce:
===================
1. Create a data  domain using the RHGS nodes
2. Remove it gracefully
3. Check for files in the RHGS bricks

Actual results:
================
Found one zero size file in the RHGS bricks after removing the Data domain.

Expected results:
=================
No data domain related files should present in the bricks after removing the data domain.

Additional info:
Comment 1 Allon Mureinik 2016-01-10 03:43:29 EST
Byreddy, can you attach VDSM's log please?
Comment 2 Maor 2016-01-13 06:57:19 EST
Seems like this behavior happens for every file Storage Domain, though the __DIRECT_IO_TEST__ has no real effect for the Storage server.
Nir is there any reason why we want to keep this file once the Storage Domain gets removed?
Comment 3 Nir Soffer 2016-01-13 10:54:00 EST
(In reply to Maor from comment #2)
> Seems like this behavior happens for every file Storage Domain, though the
> __DIRECT_IO_TEST__ has no real effect for the Storage server.
> Nir is there any reason why we want to keep this file once the Storage
> Domain gets removed?

No, we don't have any reason to keep it.

This file is used for checking if direct I/O works with this domain. After
we finished the check, we can remove the file, but we don't have any lock
on the domain, so we just leave it.
See vdsm/storage/fileSD.py lineno 89.

When we format a domain we may remove this file, but I don't see any
need to do this. Do we promise somewhere that we remove all files in 
a domain directory after we remove a domain?
Comment 4 Tal Nisan 2016-01-13 12:04:07 EST
Moving to 4.0 based on Nir's comment
Comment 5 Maor 2016-01-13 12:30:26 EST
(In reply to Nir Soffer from comment #3)
> (In reply to Maor from comment #2)
> > Seems like this behavior happens for every file Storage Domain, though the
> > __DIRECT_IO_TEST__ has no real effect for the Storage server.
> > Nir is there any reason why we want to keep this file once the Storage
> > Domain gets removed?
> 
> No, we don't have any reason to keep it.
> 
> This file is used for checking if direct I/O works with this domain. After
> we finished the check, we can remove the file, but we don't have any lock
> on the domain, so we just leave it.
> See vdsm/storage/fileSD.py lineno 89.
> 
> When we format a domain we may remove this file, but I don't see any
> need to do this. Do we promise somewhere that we remove all files in 
> a domain directory after we remove a domain?

Basically no, while we can reuse the Storage Domain after it's being formatted I don't think there is any problem.
Byreddy, is the __DIRECT_IO_TEST__ file reflects any bug or there is any issue that is being blocked because of this file?
Comment 6 Byreddy 2016-01-13 21:25:03 EST
(In reply to Maor from comment #5)
> (In reply to Nir Soffer from comment #3)
> > (In reply to Maor from comment #2)
> > > Seems like this behavior happens for every file Storage Domain, though the
> > > __DIRECT_IO_TEST__ has no real effect for the Storage server.
> > > Nir is there any reason why we want to keep this file once the Storage
> > > Domain gets removed?
> > 
> > No, we don't have any reason to keep it.
> > 
> > This file is used for checking if direct I/O works with this domain. After
> > we finished the check, we can remove the file, but we don't have any lock
> > on the domain, so we just leave it.
> > See vdsm/storage/fileSD.py lineno 89.
> > 
> > When we format a domain we may remove this file, but I don't see any
> > need to do this. Do we promise somewhere that we remove all files in 
> > a domain directory after we remove a domain?
> 
> Basically no, while we can reuse the Storage Domain after it's being
> formatted I don't think there is any problem.
> Byreddy, is the __DIRECT_IO_TEST__ file reflects any bug or there is any
> issue that is being blocked because of this file?

There is no any functionality loss because of this. This issue observed when i was testing RHEV-RHGS integration. if we want to use the RHGS node (VM) after deleting  data domain for some other purpose without adding to RHEV then the RHGS volume bricks will have this file (__DIRECT_IO_TEST_) created by RHEV.

i am expecting what ever RHEV created when data domain created, it should cleanup properly when it's removed

There is no any thing blocking because of this issue.
Comment 7 Allon Mureinik 2016-01-14 07:51:57 EST
(In reply to Byreddy from comment #6)
> i am expecting what ever RHEV created when data domain created, it should
> cleanup properly when it's removed

Agreed.
Since this [bad] behavior is nothing new, and given the upcoming deadlines, setting the target for 4.0
Comment 8 Yaniv Kaul 2016-03-13 11:23:17 EDT
Unless I'm missing something, this is a nitpick with no side effect. Closing as WONTFIX for now. Please re-open if there's a justification to fix it.

Note You need to log in before you can comment on or make changes to this bug.