This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 129115 - Another victim of TERM=gnome
Another victim of TERM=gnome
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 129152 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-04 01:36 EDT by Michal Jaegermann
Modified: 2014-03-16 22:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 00:28:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-08-04 01:36:51 EDT
Description of problem:

In /etc/bashrc there is the following code:

# are we an interactive shell?
if [ "$PS1" ]; then
    case $TERM in
        xterm*)
                if .....

It looks that it should be 'xterm*|gnome)' nowadays although
this does not help me at all if I am logging to a remote running
something earlier than FC3t1.  Sigh!

There are assorted traps of that sort all over the place.

Version-Release number of selected component (if applicable):
setup-2.5.33-1
Comment 1 Bill Nottingham 2004-08-10 16:35:26 EDT
In a holding pattern waiting for final decisions on TERM=gnome or not.
Comment 2 Bill Nottingham 2004-08-10 16:40:37 EDT
*** Bug 129152 has been marked as a duplicate of this bug. ***
Comment 3 Joshua M. Thompson 2004-08-11 16:05:29 EDT
If we have to live with TERM=gnome it would be nice if there was at
least an updated /etc/bashrc pushed out as an update for FC1 and FC2.
Comment 4 Bill Nottingham 2004-09-23 00:28:10 EDT
TERM=gnome is dead.

Note You need to log in before you can comment on or make changes to this bug.