This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1291207 - Bogus log "OSError: [Errno 2] No such file or directory" for 'remove_me' image deletion while deleting an image from export domain
Bogus log "OSError: [Errno 2] No such file or directory" for 'remove_me' imag...
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.17.10
x86_64 Unspecified
unspecified Severity low (vote)
: ovirt-3.6.2
: 4.17.16
Assigned To: Nir Soffer
Elad
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 05:03 EST by Elad
Modified: 2016-02-18 06:18 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1292092 (view as bug list)
Environment:
Last Closed: 2016-02-18 06:18:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
tnisan: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
engine.log, vdsm.log (562.93 KB, application/x-gzip)
2015-12-14 05:03 EST, Elad
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 50589 master MERGED fileSD: Do not try to remove non-existent lease file 2015-12-17 14:08 EST
oVirt gerrit 51132 ovirt-3.6 MERGED fileSD: Do not try to remove non-existent lease file 2016-01-04 07:09 EST

  None (edit)
Description Elad 2015-12-14 05:03:44 EST
Created attachment 1105538 [details]
engine.log, vdsm.log

Description of problem:
While deleting an image from export domain, a "OSError: [Errno 2] No such file or directory" error is thrown in vdsm.log for the 'remove_me' image created during image deletion process.


Version-Release number of selected component (if applicable):
rhevm-3.6.1.3-0.1.el6.noarch
vdsm-4.17.13-1.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Export a VM with disk to export domain
2. Remove the VM from export domain


Actual results:
vdsm.log:

jsonrpc.Executor/1::ERROR::2015-12-14 10:44:56,320::fileSD::409::Storage.StorageDomain::(deleteImage) vol: /rhev/data-center/mnt/10.35.64.11:_vol_RHEV_Storage_elad_3/e89bff1b-b661-419a-85cc-1b083219879b/images/_re
move_me_e5b31639-bf4d-475d-b286-fbd09ae835c0/6f3b44a7-60f4-4c5a-8e33-5c0bd592d04d can't be removed.
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/fileSD.py", line 406, in deleteImage
    self.oop.os.remove(leaseFile)
  File "/usr/share/vdsm/storage/outOfProcess.py", line 246, in remove
    self._iop.unlink(path)
  File "/usr/lib/python2.7/site-packages/ioprocess/__init__.py", line 491, in unlink
    return self._sendCommand("unlink", {"path": path}, self.timeout)
  File "/usr/lib/python2.7/site-packages/ioprocess/__init__.py", line 427, in _sendCommand
    raise OSError(errcode, errstr)
OSError: [Errno 2] No such file or directory
jsonrpc.Executor/1::DEBUG::2015-12-14 10:44:56,320::fileSD::410::Storage.StorageDomain::(deleteImage) Removing directory: /rhev/data-center/mnt/10.35.64.11:_vol_RHEV_Storage_elad_3/e89bff1b-b661-419a-85cc-1b083219
879b/images/_remove_me_e5b31639-bf4d-475d-b286-fbd09ae835c0

The image seems to be removed successfully.

Expected results:
No error.

Additional info:
engine.log, vdsm.log
Comment 1 Nir Soffer 2015-12-14 13:23:24 EST
We are planning to remove export domain in 4.0, so this will never be fixed in upstream.

Can be a small fix for 3.6. If storage domain does not support leases, do not remove them.
Comment 2 Allon Mureinik 2015-12-15 03:49:01 EST
Nir, can you explain the flow that produces this error please? I'm not quite clear from the existing BZ description.
Comment 3 Tal Nisan 2015-12-15 05:17:57 EST
Aside for that Nir, resetting the assignee and removing the target version does not make the bug disappear, if you think it shouldn't be fixed, explain why and move to CLOSED - WONTFIX
Comment 4 Nir Soffer 2015-12-15 05:33:47 EST
(In reply to Tal Nisan from comment #3)
I did not change it, probably bugzilla race.
Comment 5 Tal Nisan 2015-12-16 01:52:36 EST
OK, and as Allon requested, please explain the flow here so we can decide whether to close or target and assign someone
Comment 6 Nir Soffer 2015-12-16 07:15:11 EST
(In reply to Allon Mureinik from comment #2)
> Nir, can you explain the flow that produces this error please? I'm not quite
> clear from the existing BZ description.

According to the description, deleting a volume on an export domain. Since we do
not use sanlock on export domain, there is no lease file, and unlink operation
fails.
Comment 7 Nir Soffer 2015-12-16 07:17:04 EST
Sorry, bugzilla clash again.
Comment 8 Nir Soffer 2015-12-16 07:21:51 EST
Elad, can you check that the attach patch fixes the issue?
Comment 9 Nir Soffer 2015-12-16 07:47:08 EST
Since the fix is trivial, and testing is very easy, I think we should address this
in 3.6.3.

Changing the severity to low, since this does not effect the delete operation.

Not sure if we should backport it. Tal, what do you think?
Comment 10 Tal Nisan 2015-12-16 08:22:02 EST
Let's leave it for now, we'll see what the PMs say next meeting
Comment 11 Aharon Canan 2015-12-16 09:01:31 EST
(In reply to Nir Soffer from comment #8)
> Elad, can you check that the attach patch fixes the issue?

Is it critical to test the patch in QA ?
It can take us some time to get to it. did you test it on your side?
Comment 12 Nir Soffer 2015-12-20 04:15:49 EST
(In reply to Aharon Canan from comment #11)
> (In reply to Nir Soffer from comment #8)
> > Elad, can you check that the attach patch fixes the issue?
> 
> Is it critical to test the patch in QA ?
> It can take us some time to get to it. did you test it on your side?

Tested and merged.
Comment 13 Elad 2016-01-17 08:27:33 EST
While deleting an image from an export domain, only the volume and its meta file are being removed. No attempt to remove a lease file. No error is raised.

Verified using
vdsm-4.17.17-0.el7ev.noarch
rhevm-3.6.2.5-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.