Bug 1291221 - virsh install error should be more intuitive
virsh install error should be more intuitive
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 05:55 EST by Laura Novich
Modified: 2016-01-26 20:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 06:30:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laura Novich 2015-12-14 05:55:24 EST
Description of problem:
When running yum install virsh, it returns - no package available. This is not wrong, but it does not help the user as it doesn't give any alternative.

Instead of displaying:
No package virsh available.
Error: Nothing to do

It would be better to state:

No package virsh available.
Error: Nothing to do

Resolution:
virsh is included in the libvirt-client package. Run yum install libvirt-client to install virsh.

or something similar.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Jiri Denemark 2015-12-14 06:30:18 EST
You can use yum provides '*/virsh'

Note You need to log in before you can comment on or make changes to this bug.