Bug 1291253 - eclipse - !MESSAGE Could not instantiate provider org.eclipse.team.svn.core.svnnature for project
eclipse - !MESSAGE Could not instantiate provider org.eclipse.team.svn.core.s...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse-subclipse (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Mat Booth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 07:38 EST by lejeczek
Modified: 2015-12-14 08:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 08:35:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lejeczek 2015-12-14 07:38:31 EST
Description of problem:

I cannot run Eclipse, -clean does not help neither.

!STACK 1
org.eclipse.team.core.TeamException: Could not instantiate provider org.eclipse.team.svn.core.svnnature for project CCNR.docs.
        at org.eclipse.team.core.RepositoryProvider.mapNewProvider(RepositoryProvider.java:165)
        at org.eclipse.team.core.RepositoryProvider.mapExistingProvider(RepositoryProvider.java:235)
        at org.eclipse.team.core.RepositoryProvider.getProvider(RepositoryProvider.java:507)
        at org.eclipse.team.internal.core.TeamHookDispatcher.getProvider(TeamHookDispatcher.java:97)
        at org.eclipse.team.internal.core.TeamHookDispatcher.getRuleFactory(TeamHookDispatcher.java:105)
        at org.eclipse.core.internal.resources.Rules.factoryFor(Rules.java:97)
        at org.eclipse.core.internal.resources.Rules.refreshRule(Rules.java:177)
        at org.eclipse.core.internal.resources.Resource.refreshLocal(Resource.java:1583)
        at org.eclipse.core.internal.refresh.RefreshJob.runInWorkspace(RefreshJob.java:169)
        at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:39)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
!SUBENTRY 1 org.eclipse.team.core 4 0 2015-12-14 12:14:24.049
!MESSAGE Could not instantiate provider org.eclipse.team.svn.core.svnnature for project 

Version-Release number of selected component (if applicable):

eclipse-subclipse-1.10.9-1.fc22.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Mat Booth 2015-12-14 08:35:53 EST
It looks like your project was configured with "Subversive" (not packaged in Fedora.)

You may be able to convert your project to be compatible with Subclipse: http://stackoverflow.com/questions/5682524/converting-subversive-projectsets-to-subclipse

Or you may prefer to install the Subversive tooling from upstream: https://www.eclipse.org/subversive/downloads.php


Either way, this is not a Subclipse bug.

Note You need to log in before you can comment on or make changes to this bug.