Bug 1291306 - backport to icehouse: Error: Unable to connect to Neutron" is displayed when instance table displays many instances over 150
backport to icehouse: Error: Unable to connect to Neutron" is displayed when ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
5.0 (RHEL 7)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 5.0 (RHEL 6)
Assigned To: Matthias Runge
Ido Ovadia
: TestOnly, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 09:30 EST by Eduard Barrera
Modified: 2016-04-18 12:37 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-django-horizon-2014.1.5-2.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-18 12:37:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1349841 None None None Never

  None (edit)
Description Eduard Barrera 2015-12-14 09:30:02 EST
Description of problem:

When I displayed over 150 instances in a single page of instance table, I always got "Error: Unable to connect to Neutron".
The instance table itself is displayed properly, so I think the priority is low.

The error is RequestURITooLong from api.neutron.servers_update_addresses().
This method calls port_list with port_id filter parameters and too many port_id can be passed.
As a result URI line becomes too long and the above exception is raised.

It is better not to display such error message and deal with RequestURITooLong exception in api/neutron.

Note that we can avoid by setting API_RESULT_LIMIT to around 100 (the default value is 1000).


https://bugs.launchpad.net/horizon/+bug/1349841

Version-Release number of selected component (if applicable):
icehouse

How reproducible:
displayed over 150 instances in a single page of instance table

Steps to Reproduce:
1.
2.
3.

Actual results:
Error: Unable to connect to Neutron

Expected results:
no error

Additional info:
Comment 2 Matthias Runge 2015-12-14 10:27:52 EST
there is already a bug for this: https://bugzilla.redhat.com/show_bug.cgi?id=1160599

*** This bug has been marked as a duplicate of bug 1160599 ***
Comment 5 Lon Hohberger 2016-03-15 16:09:46 EDT
According to our records, this should be resolved by python-django-horizon-2014.1.5-2.el6ost.  This build is available now.
Comment 6 Ido Ovadia 2016-03-28 08:02:49 EDT
Verified
========
python-django-horizon-2014.1.5-2.el6ost.noarch

Note You need to log in before you can comment on or make changes to this bug.