Bug 1291308 - Cannot detach cinder volume [NEEDINFO]
Cannot detach cinder volume
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
high Severity high
: ---
: 6.0 (Juno)
Assigned To: Lee Yarwood
nlevinki
: Unconfirmed, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 09:39 EST by Jeremy
Modified: 2015-12-15 07:06 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 07:06:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lyarwood: needinfo? (jmelvin)


Attachments (Terms of Use)

  None (edit)
Description Jeremy 2015-12-14 09:39:53 EST
Description of problem:
launched  an instance with the following command :

[root@aio ~(admin)]# nova boot --flavor m1.small --image CentOS-6.6-gen  --nic net-id=cd65ac88-f60a-4af9-8b17-62e18bb9127f --block-device id=3ab8f80f-d71d-4c23-bc69-8d2c5d04ce3b,source=volume,dest=volume,bus=ide,size=1,device=/dev/vdb,type=cdrom,bootindex=1 VM-cdrom

The problem is that I cannot detach the volume ( was attached as cdrom )    neither via horizon nor via command line  although there is no any error takes place .


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. nova boot --flavor m1.small --image CentOS-6.6-gen  --nic net-id=cd65ac88-f60a-4af9-8b17-62e18bb9127f --block-device id=3ab8f80f-d71d-4c23-bc69-8d2c5d04ce3b,source=volume,dest=volume,bus=ide,size=1,device=/dev/vdb,type=cdrom,bootindex=1 VM-cdrom
2.
3.

Actual results:


Expected results:


Additional info:

+--------------------------------------+----------------------------------------------------------+
| Property                             | Value                                                    |
+--------------------------------------+----------------------------------------------------------+
| OS-DCF:diskConfig                    | MANUAL                                                   |
| OS-EXT-AZ:availability_zone          | nova                                                     |
| OS-EXT-SRV-ATTR:host                 | aio.il.nds.com                                           |
| OS-EXT-SRV-ATTR:hypervisor_hostname  | aio.il.nds.com                                           |
| OS-EXT-SRV-ATTR:instance_name        | instance-0000003a                                        |
| OS-EXT-STS:power_state               | 1                                                        |
| OS-EXT-STS:task_state                | -                                                        |
| OS-EXT-STS:vm_state                  | active                                                   |
| OS-SRV-USG:launched_at               | 2015-12-07T10:58:04.000000                               |
| OS-SRV-USG:terminated_at             | -                                                        |
| accessIPv4                           |                                                          |
| accessIPv6                           |                                                          |
| config_drive                         |                                                          |
| created                              | 2015-12-07T10:57:46Z                                     |
| flavor                               | m1.small (2)                                             |
| hostId                               | 6dcb1da890207286323df31d72bb175d52e18515087f6b9d28ad5677 |
| id                                   | 88c5caa5-01b8-410b-8d27-457eb599d177                     |
| image                                | CentOS-6.6-gen (9be95525-b001-4e46-a56c-e23c9b0eaca4)    |
| key_name                             | -                                                        |
| metadata                             | {}                                                       |
| name                                 | VM-cdrom                                                 |
| os-extended-volumes:volumes_attached | [{"id": "3ab8f80f-d71d-4c23-bc69-8d2c5d04ce3b"}]         |
| priv1 network                        | 192.168.0.63                                             |
| progress                             | 0                                                        |
| security_groups                      | default                                                  |
| status                               | ACTIVE                                                   |
| tenant_id                            | 0975965442d044979ecc43e063768039                         |
| updated                              | 2015-12-07T10:58:04Z                                     |
| user_id                              | 95ad21f4c29b475ab5c64270cf3fde94                         |
+--------------------------------------+----------------------------------------------------------+
+--------------------------------------+--------+--------------+------+---------------+----------+--------------------------------------+
|                  ID                  | Status | Display Name | Size |  Volume Type  | Bootable |             Attached to              |
+--------------------------------------+--------+--------------+------+---------------+----------+--------------------------------------+
| 3ab8f80f-d71d-4c23-bc69-8d2c5d04ce3b | in-use |  empty-vol   |  20  | disk_cdrom    |  false   | 88c5caa5-01b8-410b-8d27-457eb599d177 |
+--------------------------------------+--------+--------------+------+---------------+----------+--------------------------------------+
+---------------------------------------+--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
|                Property               |                                                                                                    Value                                                                                                     |
+---------------------------------------+--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
|              attachments              | [{u'device': u'/dev/vdb', u'server_id': u'88c5caa5-01b8-410b-8d27-457eb599d177', u'id': u'3ab8f80f-d71d-4c23-bc69-8d2c5d04ce3b', u'host_name': None, u'volume_id': u'3ab8f80f-d71d-4c23-bc69-8d2c5d04ce3b'}] |
|           availability_zone           |                                                                                                     nova                                                                                                     |
|                bootable               |                                                                                                    false                                                                                                     |
|               created_at              |                                                                                          2015-10-11T10:45:11.000000                                                                                          |
|          display_description          |                                                                                                                                                                                                              |
|              display_name             |                                                                                                  empty-vol                                                                                                   |
|               encrypted               |                                                                                                    False                                                                                                     |
|                   id                  |                                                                                     3ab8f80f-d71d-4c23-bc69-8d2c5d04ce3b                                                                                     |
|                metadata               |                                                                               {u'readonly': u'False', u'attached_mode': u'rw'}                                                                               |
|         os-vol-host-attr:host         |                                                                                            aio.il.nds.com@lvm#lvm                                                                                            |
|     os-vol-mig-status-attr:migstat    |                                                                                                     None                                                                                                     |
|     os-vol-mig-status-attr:name_id    |                                                                                                     None                                                                                                     |
|      os-vol-tenant-attr:tenant_id     |                                                                                       0975965442d044979ecc43e063768039                                                                                       |
|   os-volume-replication:driver_data   |                                                                                                     None                                                                                                     |
| os-volume-replication:extended_status |                                                                                                     None                                                                                                     |
|                  size                 |                                                                                                      20                                                                                                      |
|              snapshot_id              |                                                                                                     None                                                                                                     |
|              source_volid             |                                                                                                     None                                                                                                     |
|                 status                |                                                                                                    in-use                                                                                                    |
|              volume_type              |                                                                                                disk_cdrom                                                                                                    |
Comment 1 Lee Yarwood 2015-12-15 06:35:33 EST
Jeremy, is this the issue we discussed internally? If it is the reason was clearly visable in my compute logs when testing this :

libvirtError: Operation not supported: disk device type 'cdrom' cannot be detached

As a workaround you can however remove this volume offline with the following :

nova stop $instance ; nova volume-detach $instance $volume ; nova start $instance 

Can you confirm so we can close this out as NOTABUG please?

Note You need to log in before you can comment on or make changes to this bug.