Bug 129136 - curl fails to download long ftp url file of size 1.5M (reclassify as kernel bug)
Summary: curl fails to download long ftp url file of size 1.5M (reclassify as kernel bug)
Status: CLOSED DUPLICATE of bug 129204
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-04 12:40 UTC by Goh Kim Leng
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Goh Kim Leng 2004-08-04 12:40:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
curl fails to download long ftp url file of size 1.5M:

curl -C - -O ftp://ftp.tin.org/pub/news/clients/tin/stable/tin-
current.tar.gz
  % Total    % Received % Xferd  Average Speed          
Time             Curr.
                                 Dload  Upload Total    Current  
Left    Speed
  0     0    0     0    0     0      0      0 --:--:--  0:01:11 --:--
:--     0

however, another url works:
curl -C - -O ftp://ftp.funet.fi/pub/unix/news/tin-unoff/tin-
current.tar.gz
** Resuming transfer from byte position 24576
  % Total    % Received % Xferd  Average Speed          
Time             Curr.
                                 Dload  Upload Total    Current  
Left    Speed
  4 1488k    4 68400    0     0   1709      0  0:14:51  0:00:40  
0:14:11  1362

Version-Release number of selected component (if applicable):
curl-7.11.1-1

How reproducible:
Always

Steps to Reproduce:
1. type curl -C - -O 
ftp://ftp.tin.org/pub/news/clients/tin/stable/tin-current.tar.gz
    

Additional info:

kernel release is 2.6.7-1.494.2.2smp

Comment 1 Goh Kim Leng 2004-08-07 04:55:45 UTC
I've reclassified the component from curl to kernel. This is because 
this version of curl works under kernel-smp-2.6.6-1.435.2.3 for the 
specific example above. 

Moreover, I discovered that the average speed for downloads via wget 
or elinks for kernel-2.6.7-1.494.2.2smp was in B/s. The file I was 
attempting to download was the J2SE v 1.4.2_05 SDK RPM in self-
extracting file. On the other hand, the download using kernel-smp-
2.6.6-1.435.2.3 was in K/s.

Comment 2 Goh Kim Leng 2004-08-07 05:05:02 UTC

*** This bug has been marked as a duplicate of 129204 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:04:56 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.