Bug 129140 - Postscript page is not rendered nor printed correctly
Postscript page is not rendered nor printed correctly
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ghostscript (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-04 09:41 EDT by reubendb
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:21:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sampe Postscript file that doesn't work in ggv/gv (81.39 KB, application/postscript)
2004-08-04 09:45 EDT, reubendb
no flags Details
PDF version of the previously attached ps file (23.06 KB, application/pdf)
2004-08-04 09:46 EDT, reubendb
no flags Details

  None (edit)
Description reubendb 2004-08-04 09:41:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
First, I'm not very sure if this is ghostscript or ggv problem, but it
looks like more ghostscript problem (correct me if I'm wrong). 

The following (attached) postscript file is not rendered correctly
using  ggv. It's a 3 pages file, with mostly graphics in second and
third page. ggv only shows page 1 and part of page 2. And the page
number interface (on the left side bar) in ggv is wrong, it only shows
3,3. 

I installed ghostview (gv) that's recompiled for RHEL (non-supported
of course) from : http://people.redhat.com/tcallawa/RHEL3/
This version of gv shows all 3 pages, but will only print page 1.

Directly invoking 'lpr <filename.ps>' on this ps file resulted only
page 1 is printed also, which makes me suspect the problem is more in
ghostscript.

The only workaround that I have is to convert this to pdf using
'ps2pdf', and print the pdf file using acroread, which works fine (PDF
file also attached for comparison). The conversion back from pdf to ps
using pdf2ps, pdftops, or 'print to file' from acroread seems to be OK
too, and gv/ggv has no trouble reading that file.

I confirmed this same problem with Fedora Core 1 and Fedora Core 2.
This problem does *not* exist in Redhat 7.3 though.

BTW, this postscript file is an output from Maple 7 software for linux
(using 'print to file' command). Printing directly from Maple 7 gives
the same problem (only first page and part of second page printed out).



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open the attached ps file using ggv


Actual Results:  Only page 1 and part of page 2 is viewable and printable

Expected Results:  All pages should be viewable and printable, just
like the PDF version of the file created using ps2pdf.

Additional info:
Comment 1 reubendb 2004-08-04 09:45:09 EDT
Created attachment 102417 [details]
Sampe Postscript file that doesn't work in ggv/gv
Comment 2 reubendb 2004-08-04 09:46:14 EDT
Created attachment 102418 [details]
PDF version of the previously attached ps file

PDF version of the previously attached ps file, created using ps2pdf.
Comment 3 Alex Cherepanov 2005-03-06 09:18:31 EST
The PS file is not DSC-conforming.
I can help with detection of PS files that claim DSC conformance but
fail to deliver it if there's some interest in this project on RH side.
Comment 4 RHEL Product and Program Management 2007-10-19 15:21:33 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.