Bug 1291402 - FANOTIFY - Add patch for listening daemon's own opens to be pre-approved
FANOTIFY - Add patch for listening daemon's own opens to be pre-approved
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel (Show other bugs)
7.2
Unspecified Linux
high Severity medium
: rc
: ---
Assigned To: Eric Sandeen
xzhou
:
Depends On:
Blocks: 1296180 1313485 1295577
  Show dependency treegraph
 
Reported: 2015-12-14 14:42 EST by Steve Grubb
Modified: 2016-06-30 12:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-30 12:21:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2015-12-14 14:42:12 EST
Description of problem:
If a daemon using FANOTIFY needs to open a file on a watched filesystem and
its wanting OPEN_PERM events, we get deadlock. (This could happen because
of a library the daemon is using suddenly decides it needs to look in a new
file.) 

Additional info:
Patch allowing this is posted upstream:
http://lkml.iu.edu/hypermail/linux/kernel/1510.1/03342.html
Comment 9 Eric Sandeen 2016-01-28 11:14:18 EST
I sent a patch based on sgrubb's, moving "policy" to userspace at open time to fsdevel, and Jan Kara dumped cold water on that too.  As I am really not an expert in the subsystem or the usecase here, it'd be great to have sgrubb et al chime in with ideas and opinions on fsdevel...
Comment 10 Eric Sandeen 2016-06-30 12:18:03 EDT
This has never been agreed to or merged upstream, moving to 7.4 for now.
Comment 11 Steve Grubb 2016-06-30 12:21:38 EDT
This can actually be closed. I am making different plans to solve the problem. I do appreciate all the help on it.

Note You need to log in before you can comment on or make changes to this bug.