Bug 1291411 - Program terminated with signal SIGSEGV, Segmentation fault.
Program terminated with signal SIGSEGV, Segmentation fault.
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 15:08 EST by poma
Modified: 2016-01-25 15:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 15:14:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
coredump gnome-shell 20520 (23.07 KB, text/plain)
2015-12-14 15:08 EST, poma
no flags Details
coredump gnome-shell 14297 (25.64 KB, text/plain)
2015-12-17 13:47 EST, poma
no flags Details

  None (edit)
Description poma 2015-12-14 15:08:35 EST
Created attachment 1105665 [details]
coredump gnome-shell 20520

Description of problem:
Program terminated with signal SIGSEGV, Segmentation fault.

Version-Release number of selected component (if applicable):
gnome-shell-3.19.2-2.fc24.x86_64

How reproducible:
101%

Steps to Reproduce:
1. Run "xrandr --output <output> --off"

Actual results:
The same as with
"gnome-session-quit --logout --force --no-prompt"
i.e. bumped to gdm greeter

Expected results:
Just disable the output.

Additional info:
Something similar happens with Xfwm4 GL compositor, but not to this extent as Mutter breaking.
For a better comparison, doesn't affect Xfwm4 XRender compositor.

Aye
Comment 1 poma 2015-12-14 20:19:54 EST
Common denominator: meta_monitor_manager_xrandr_handle_xevent

https://bugzilla.gnome.org/buglist.cgi?quicksearch=meta_monitor_manager_xrandr_handle_xevent
https://bugzilla.redhat.com/buglist.cgi?quicksearch=meta_monitor_manager_xrandr_handle_xevent

Also tested with:
clutter-1.25.1-1.20151213git1c9e297.fc24.x86_64
mutter-3.19.2-2.20151214gitf5f26c9.fc24.x86_64
Comment 2 Florian Müllner 2015-12-16 09:05:53 EST
(In reply to poma from comment #0)
> Expected results:
> Just disable the output.

Is this *an* output or *the* output? Upstream mutter still doesn't support running without any outputs connected, see https://bugzilla.gnome.org/show_bug.cgi?id=730551
Comment 3 poma 2015-12-16 15:38:23 EST
(In reply to Florian Müllner from comment #2)
> (In reply to poma from comment #0)
> > Expected results:
> > Just disable the output.
> 
> Is this *an* output or *the* output? Upstream mutter still doesn't support
> running without any outputs connected, see
> https://bugzilla.gnome.org/show_bug.cgi?id=730551


Actual oneliner is:
$ xrandr --output DVI-I-1 --off ; sleep 5 ; xrandr --auto

but for the test enough is
$ xrandr --output DVI-I-1

because it is sufficient for - gnome-shell out of business -
Comment 4 poma 2015-12-16 16:52:47 EST
(In reply to Florian Müllner from comment #2)
> (In reply to poma from comment #0)
> > Expected results:
> > Just disable the output.
> 
> Is this *an* output or *the* output? Upstream mutter still doesn't support
> running without any outputs connected, see
> https://bugzilla.gnome.org/show_bug.cgi?id=730551


Besides,

https://bugzilla.gnome.org/show_bug.cgi?id=730551#c12
https://github.com/endlessm/mutter/commit/e9fbb10.patch
...
+ echo 'Patch #1 (0001-Do-not-crash-when-starting-up-with-no-monitor-connec.patch):'
Patch #1 (0001-Do-not-crash-when-starting-up-with-no-monitor-connec.patch):
+ /usr/bin/patch -p1 --fuzz=0
patching file src/core/constraints.c
Hunk #1 succeeded at 29 (offset -2 lines).
Hunk #2 succeeded at 326 (offset -29 lines).
Hunk #3 FAILED at 414.
Hunk #4 FAILED at 458.
2 out of 4 hunks FAILED -- saving rejects to file src/core/constraints.c.rej
patching file src/core/place.c
Hunk #1 FAILED at 860.
1 out of 1 hunk FAILED -- saving rejects to file src/core/place.c.rej
patching file src/core/screen.c
Hunk #1 succeeded at 386 (offset -10 lines).
Hunk #2 FAILED at 1871.
1 out of 2 hunks FAILED -- saving rejects to file src/core/screen.c.rej
patching file src/core/window.c
Hunk #1 FAILED at 1356.
Hunk #2 succeeded at 2849 (offset -841 lines).
Hunk #3 succeeded at 2875 (offset -841 lines).
Hunk #4 FAILED at 4723.
Hunk #5 FAILED at 4737.
Hunk #6 FAILED at 9956.
4 out of 6 hunks FAILED -- saving rejects to file src/core/window.c.rej
error: Bad exit status from /var/tmp/rpm-tmp.heRziN (%prep)
...

And, generally speaking
https://github.com/endlessm/mutter
ain't buildable on Rawhide, at least with my attempt to do so.
Comment 5 poma 2015-12-17 05:23:19 EST
With
mutter-3.19.3-1.fc24.x86_64
- https://git.gnome.org/browse/mutter/tree/NEWS#n5
login to GNOME on Xorg is broken - gnome-settings-daemon:
Program terminated with signal SIGTRAP, Trace/breakpoint trap.
#0  0x00007f7f97a26a8b in _g_log_abort (breakpoint=1) at gmessages.c:324
324	    G_BREAKPOINT ();

the same goes with
gnome-shell-3.19.3-1.fc24.x86_64
Comment 6 poma 2015-12-17 13:47 EST
Created attachment 1106815 [details]
coredump gnome-shell 14297
Comment 7 poma 2016-01-21 06:46:10 EST
Is anyone working on a solution?

Note You need to log in before you can comment on or make changes to this bug.