Bug 1291423 - syslinux spec file uses non-existent %{x86_64} rpm macro
syslinux spec file uses non-existent %{x86_64} rpm macro
Status: CLOSED DUPLICATE of bug 1308298
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 15:44 EST by giulioo
Modified: 2016-02-16 13:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 13:55:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Change %{x86_64} into x86_64 (891 bytes, patch)
2015-12-14 15:44 EST, giulioo
no flags Details | Diff

  None (edit)
Description giulioo 2015-12-14 15:44:17 EST
Created attachment 1105681 [details]
Change %{x86_64} into x86_64

Description of problem:
RPM spec file uses 4 times the test
   %ifarch %{x86_64}
 
AFAIK, there's no such %{x86_64} rpm macro, so that the syslinux-efi64 rpm never
 gets built.
 
 
Version-Release number of selected component (if applicable):
syslinux-6.03-6.fc24.src.rpm
 
How reproducible:
Always
 
Steps to Reproduce:
On an x86_64 system:
rpmbuild --rebuild syslinux-6.03-6.fc24.src.rpm

Actual results:
No syslinux-efi64 rpm built
 
For example, look into
http://fedora.mirrors.ovh.net/linux/development/rawhide/x86_64/os/Packages/s/
and syslinux-efi64 is not there
 
Expected results:
syslinux-efi64 rpm built


Attaching patch
Comment 1 poma 2015-12-19 05:10:35 EST
+1
Syslinux EFI x64
http://www.syslinux.org/archives/2015-December/024670.html
Comment 2 poma 2016-02-13 23:42:01 EST
See Also:
https://bugzilla.redhat.com/show_bug.cgi?id=1308298
Comment 3 poma 2016-02-16 10:39:11 EST
giulioo, would you mind close this one as a duplicate of bug 1308298,
so they are no longer three, but one cumulative effort.
Comment 4 giulioo 2016-02-16 13:55:13 EST

*** This bug has been marked as a duplicate of bug 1308298 ***

Note You need to log in before you can comment on or make changes to this bug.