Bug 1291454 - DR 1 - Missing teiid-extension.cli script
DR 1 - Missing teiid-extension.cli script
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Installer, Configuration (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ER1
: 6.3.0
Assigned To: Van Halbert
Filip Elias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 16:48 EST by Van Halbert
Modified: 2016-08-24 07:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 07:43:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Van Halbert 2015-12-15 08:34:58 EST
The installer is still calling the tepid-extension.cli script.   This was done at the request of productization in a prior release.

In Dv 6.2, the line [1] was removed from the standalone and domain teiid scripts, and was instead issued in the teiid-extension.cli script.  

Now, the project (product branch) has to be changed in order to re-align with what was done in 6.2. 



[1]  /extension=org.jboss.teiid:add(module=org.jboss.teiid)
Comment 4 George Varsamis 2015-12-15 09:15:07 EST
It looks like Alex reverted the change. There are 2 ways I can sort this out.

a) Change the installer not to call this script or
b) Add the script back again .

Since this is an action that happens for both standalone and domain mode, I'd rather go for a) but I'll leave this to you to decide.


(In reply to Van Halbert from comment #3)
> The installer is still calling the tepid-extension.cli script.   This was
> done at the request of productization in a prior release.
> 
> In Dv 6.2, the line [1] was removed from the standalone and domain teiid
> scripts, and was instead issued in the teiid-extension.cli script.  
> 
> Now, the project (product branch) has to be changed in order to re-align
> with what was done in 6.2. 
> 
> 
> 
> [1]  /extension=org.jboss.teiid:add(module=org.jboss.teiid)
Comment 5 Van Halbert 2015-12-15 09:19:09 EST
I vote for a) as well.  It simplifies the project to product transition.
Comment 6 George Varsamis 2015-12-15 09:52:35 EST
Great. I will ask Tom to make the change or I can change it and give him a PR.

(In reply to Van Halbert from comment #5)
> I vote for a) as well.  It simplifies the project to product transition.
Comment 7 George Varsamis 2015-12-21 09:41:03 EST
The updated installer for DR1 that Tom did on the 16th of Dec should have fixed that. If not then can you please let us know ASAP.
Comment 8 Juraj Duráni 2015-12-22 00:59:12 EST
Yes, this issue has been resolved in the updated installer.
Comment 9 Van Halbert 2016-01-25 08:34:31 EST
This has been fixed by removing that script.

Note You need to log in before you can comment on or make changes to this bug.