Bug 1291484 - Netinstall stalls during post-installation setup with continuous pcie bus errors.
Netinstall stalls during post-installation setup with continuous pcie bus err...
Status: CLOSED DUPLICATE of bug 1352233
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 17:55 EST by ghborrmann
Modified: 2016-09-25 15:38 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-25 15:38:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ghborrmann 2015-12-14 17:55:07 EST
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Trident/7.0; rv:11.0) like Gecko
Build Identifier: 

Doing a netinstall of F23 KDE, the installation goes normally until the post-installation setup phase. Normally, this lasts several minutes, then proceeds to the next phase.  This time, it stayed there for at least 10 hours.  I repeated the process, with the same result. On pressing Ctrl-Alt-F4, I noted error messages flashing by.  This was a four-line error message repeated indefinitely:

   PCIe Error Bus: severity=Corrected, type=Physical Layer, id=00e0(Receiver ID)
     device [8086:a110] error status/mask00000001/00000000
      [ 0] Receiver Error
   AER: Corrected error received: id=00e0



Reproducible: Always

Steps to Reproduce:
1. Boot from F23 netinstall disk
2. Choose to install Fedora
3. Choose custom partitioning, KDE

Actual Results:  
Installation stalls at post-installation setup

Expected Results:  
Installation proceeds to completion after a few minutes.

Researching the problem on Google, I found a suggestion to use pcie_aspm=off as a kernel option.  When I reran the installer, pressing the "e" key after choosing to install Fedora, and inserting that kernel option, the installation worked as expected.  The problem appears to be related to my hardware (a Dell XPS 8900 system), because the same thing happened when I tried to boot the installed system.  The pcie_aspm=off option worked here also.
Comment 1 Laura Abbott 2016-09-23 15:25:17 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 2 ghborrmann 2016-09-24 15:19:07 EDT
I have moved on from Fedora 23 to 24, so I have not been able to test this on a Fedora 23 system.  However, I have determined that this issue is still present on Fedora 24 (see bug #1352233).  Since Fedora 23 is nearing end of life, I would suggest closing this issue, at least until it has been fixed in Fedora 24.
Comment 3 Josh Boyer 2016-09-25 15:38:07 EDT

*** This bug has been marked as a duplicate of bug 1352233 ***

Note You need to log in before you can comment on or make changes to this bug.