Bug 1291519 - [abrt] gimp: gimp_tool_palette_size_allocate(): gimp-2.8 killed by SIGFPE
[abrt] gimp: gimp_tool_palette_size_allocate(): gimp-2.8 killed by SIGFPE
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6e18c982342f8498859ef806c59...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 22:16 EST by D. Stimits
Modified: 2016-10-26 13:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-26 13:30:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (60.74 KB, text/plain)
2015-12-14 22:16 EST, D. Stimits
no flags Details
File: cgroup (190 bytes, text/plain)
2015-12-14 22:16 EST, D. Stimits
no flags Details
File: core_backtrace (18.85 KB, text/plain)
2015-12-14 22:16 EST, D. Stimits
no flags Details
File: dso_list (10.29 KB, text/plain)
2015-12-14 22:16 EST, D. Stimits
no flags Details
File: environ (312 bytes, text/plain)
2015-12-14 22:16 EST, D. Stimits
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-14 22:16 EST, D. Stimits
no flags Details
File: maps (58.91 KB, text/plain)
2015-12-14 22:16 EST, D. Stimits
no flags Details
File: mountinfo (3.17 KB, text/plain)
2015-12-14 22:16 EST, D. Stimits
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-14 22:16 EST, D. Stimits
no flags Details
File: open_fds (892 bytes, text/plain)
2015-12-14 22:16 EST, D. Stimits
no flags Details
File: proc_pid_status (1021 bytes, text/plain)
2015-12-14 22:16 EST, D. Stimits
no flags Details

  None (edit)
Description D. Stimits 2015-12-14 22:16:37 EST
Description of problem:
Started to erase on a new layer which had transparency (new layer was a duplicate of a jpg).

Version-Release number of selected component:
gimp-2.8.16-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        gimp
crash_function: gimp_tool_palette_size_allocate
executable:     /usr/bin/gimp-2.8
global_pid:     2955
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 gimp_tool_palette_size_allocate at gimptoolpalette.c:153
 #1 g_cclosure_marshal_VOID__BOXEDv at gmarshal.c:1950
 #2 _g_closure_invoke_va at gclosure.c:864
 #5 gtk_widget_size_allocate at gtkwidget.c:4122
 #6 gtk_box_size_allocate at gtkbox.c:500
 #7 g_cclosure_marshal_VOID__BOXEDv at gmarshal.c:1950
 #8 _g_closure_invoke_va at gclosure.c:864
 #11 gtk_widget_size_allocate at gtkwidget.c:4122
 #12 gtk_box_size_allocate at gtkbox.c:500
 #13 g_cclosure_marshal_VOID__BOXEDv at gmarshal.c:1950
Comment 1 D. Stimits 2015-12-14 22:16:41 EST
Created attachment 1105815 [details]
File: backtrace
Comment 2 D. Stimits 2015-12-14 22:16:42 EST
Created attachment 1105816 [details]
File: cgroup
Comment 3 D. Stimits 2015-12-14 22:16:43 EST
Created attachment 1105817 [details]
File: core_backtrace
Comment 4 D. Stimits 2015-12-14 22:16:44 EST
Created attachment 1105818 [details]
File: dso_list
Comment 5 D. Stimits 2015-12-14 22:16:45 EST
Created attachment 1105819 [details]
File: environ
Comment 6 D. Stimits 2015-12-14 22:16:46 EST
Created attachment 1105820 [details]
File: limits
Comment 7 D. Stimits 2015-12-14 22:16:46 EST
Created attachment 1105821 [details]
File: maps
Comment 8 D. Stimits 2015-12-14 22:16:47 EST
Created attachment 1105822 [details]
File: mountinfo
Comment 9 D. Stimits 2015-12-14 22:16:48 EST
Created attachment 1105823 [details]
File: namespaces
Comment 10 D. Stimits 2015-12-14 22:16:49 EST
Created attachment 1105824 [details]
File: open_fds
Comment 11 D. Stimits 2015-12-14 22:16:50 EST
Created attachment 1105825 [details]
File: proc_pid_status
Comment 12 Nils Philippsen 2016-10-26 04:51:17 EDT
Sorry for the late response. Do you still experience this issue with the current GIMP version 2.8.18?
Comment 13 D. Stimits 2016-10-26 09:35:11 EDT
(In reply to Nils Philippsen from comment #12)
> Sorry for the late response. Do you still experience this issue with the
> current GIMP version 2.8.18?

I have had to move on to other things, and no longer have the particular jpg file to test with. I briefly ran the same operation just now on a jpg with alpha under 2.8.18 and did not see any failure. It's probably ok to close this bug, and if something else occurs, re-opening later.
Comment 14 Nils Philippsen 2016-10-26 13:30:02 EDT
Thanks for the quick reply!

Note You need to log in before you can comment on or make changes to this bug.