Bug 1291594 - [DOCS] Add WARNING to the installation guide *Not* to add the wildcard domain to /etc/resolv.conf
[DOCS] Add WARNING to the installation guide *Not* to add the wildcard domain...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity medium
: ---
: ---
Assigned To: Ashley Hardin
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 03:55 EST by Kenjiro Nakayama
Modified: 2016-01-28 15:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 15:39:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenjiro Nakayama 2015-12-15 03:55:54 EST
URL&Section:
https://docs.openshift.com/enterprise/3.1/install_config/install/prerequisites.html#prereq-dns
(Prerequisites - DNS)

Issue:

After DNS setup "*.cloudapps.example.com. 300 IN  A 192.168.133.2", some users add the domain "cloudapps.example.com" to /etc/resolv.conf's "search list". It will stop accessing via any FQDN, since the /etc/resolv.conf inside container (managed by kubernetes/OSE) has "options ndots:5".
It will look up "lookup domain" + "cloudapps.example.com" first and hit wild card DNS. (Please see [1] in Root Cause.)

Suggestions for improvement:

The troubleshooting guide[2] already mentioned about it, but that should add as WARNING to installation guide dns section[3].

Ref:

[1] https://access.redhat.com/solutions/1990683
[2] https://docs.openshift.com/enterprise/3.1/admin_guide/sdn_troubleshooting.html#debugging-pod-egress
~~~
To fix that, you either need to make sure that DNS server that has the wildcard entry is not listed as a nameserver in your /etc/resolv.conf or you need to make sure that the wildcard domain is not listed in the search list.
~~~
[3] https://docs.openshift.com/enterprise/3.1/install_config/install/prerequisites.html#prereq-dns

Document URL: 

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information:
Comment 4 Ashley Hardin 2016-01-21 10:59:58 EST
Pull request created: https://github.com/openshift/openshift-docs/pull/1460
Comment 5 Ashley Hardin 2016-01-21 16:20:25 EST
(In reply to Ashley Hardin from comment #4)
> Pull request created: https://github.com/openshift/openshift-docs/pull/1460


Pull Request https://github.com/openshift/openshift-docs/pull/1460 was closed due to an error in my push. 

New PR created:
https://github.com/openshift/openshift-docs/pull/1462
Comment 6 openshift-github-bot 2016-01-22 09:52:34 EST
Commits pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/08ca622c0638bc2d0d6dbee5a016a85a89258787
Bug 1291594, added warning admonition

https://github.com/openshift/openshift-docs/commit/4050faa63d0aaf903bbb13eeef993d4dc8f3d06b
Merge pull request #1462 from ahardin-rh/wildcard-warning

Bug 1291594, added warning admonition
Comment 7 Ashley Hardin 2016-01-28 15:39:53 EST
This is now published: https://access.redhat.com/documentation/en/openshift-enterprise/version-3.1/installation-and-configuration/#envirornment-requirements

Please let me know if you have any questions.

Note You need to log in before you can comment on or make changes to this bug.