Bug 1291615 - Summary tab content on builds page don't change its horizontal size to fit with browser size on Firefox
Summary tab content on builds page don't change its horizontal size to fit wi...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Samuel Padgett
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 04:54 EST by yapei
Modified: 2017-05-30 08:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-30 08:48:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SummaryTabContentOut (53.11 KB, image/png)
2015-12-15 04:54 EST, yapei
no flags Details
IE11BuildSummary (53.35 KB, image/png)
2016-02-17 21:05 EST, yapei
no flags Details

  None (edit)
Description yapei 2015-12-15 04:54:37 EST
Created attachment 1105945 [details]
SummaryTabContentOut

Description of problem:
On Firefox, when browser size changes, on builds page, build trends chart and table(all builds are listed) in Summary tab didn't change its horizontal size to fit with browser's size automatically, it needs refresh manually to make it display well

Version-Release number of selected component (if applicable):
openshift v1.1-442-gde31d75
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2

How reproducible:
Always

Steps to Reproduce:
1.Create application on web console, wait for complete
2.Check builds info on build page
3.Change browser size

Actual results:
3.Content in "Summary" tab didn't change its size to fit with browser's,refer to attachments

Expected results:
3.All tab contents should changes when browser size changes automatically

Additional info:
On Chrome, IE, Safari it works well
Comment 1 Samuel Padgett 2015-12-22 12:45:10 EST
Seems to be another bug in c3.js, Firefox only.
Comment 2 Samuel Padgett 2016-02-16 16:52:41 EST
https://github.com/openshift/origin/pull/7364
Comment 3 yapei 2016-02-17 21:04:27 EST
checked against devenv-rhel7_3449, Firefox44, Chrome47, Edge25,Safari9

But IE11 reproduces this issue, screenshot attached
Comment 4 yapei 2016-02-17 21:05 EST
Created attachment 1128111 [details]
IE11BuildSummary
Comment 5 Samuel Padgett 2016-12-05 08:56:37 EST
I can't reproduce this (testing IE 11). I know we've fixed some issues in IE on pages with tables. Can you check again?
Comment 6 yapei 2016-12-05 21:52:30 EST
Yeah, checked again on v1.5.0-alpha.0+ec171a1-212 with IE 11, EDGE 25, Chrome 54, Firefox 50, Safari 10.0.1 

Now the Summary tab display issue no longer exists

Move to VERIFIED

Note You need to log in before you can comment on or make changes to this bug.