Bug 1291616 - [WALA]Request to package WALA 2.0.14 into RHEL 6 Repo
[WALA]Request to package WALA 2.0.14 into RHEL 6 Repo
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: WALinuxAgent (Show other bugs)
6.7
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Dave Anderson
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 05:01 EST by mingzhan
Modified: 2016-01-07 10:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
: 1291619 1295647 (view as bug list)
Environment:
Last Closed: 2016-01-07 10:21:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mingzhan 2015-12-15 05:01:57 EST
Description of Request:
Request to package WALA 2.0.14 into REHL 6 Repo

Version-Release number of selected component (if applicable):
https://github.com/Azure/WALinuxAgent/releases/tag/WALinuxAgent-2.0.14

Impact:
2.0.14 has the hot fix for below critical bug:
Provision failure (higher rate in large size VM). 

If no 2.0.14, customer will have opportunity to hit this issue.
Comment 2 Dave Anderson 2015-12-15 10:01:17 EST
Please clarify this bugzilla.  There appear to be two separate requests:

 (1) A request to move this package from RHEL6-Extras into RHEL6.8
 (2) A request to rebase the package source code version from 2.0.13 to 2.0.14

I that correct?
Comment 3 Dave Anderson 2015-12-15 12:12:42 EST
The walinuxagent.spec file that is part of the github 2.0.14 release is
unsuitable because it is missing several items that are part of the 
current RHEL6 WALinuxAgent.spec file, which was originally derived
from a 2.0.13-based Fedora package. 

I see that there is this Fedora package:

  Information for build WALinuxAgent-2.0.14-1.el6
  http://koji.fedoraproject.org/koji/buildinfo?buildID=666562

Please review the package above, and confirm that it is what you would
expect for a RHEL6 rebase.
Comment 4 Dave Anderson 2015-12-15 14:51:39 EST
> Please review the package above, and confirm that it is what you would
> expect for a RHEL6 rebase.

In addition, the Fedora package referenced above would require these changes:

(1) This line needs to be commented out from the WALinuxAgent.spec file:

    Requires:       ntfsprogs

(2) Presumably the patch from here would need to be applied:

    BZ #1291298 - [Feature Request]WALA- RHUI support for RHEL On-Demand Image in Azure
    https://bugzilla.redhat.com/show_bug.cgi?id=1291298
Comment 5 Dave Anderson 2015-12-18 11:29:14 EST
Please respond to comments #2, #3 and #4.
Comment 6 mingzhan 2015-12-22 09:46:47 EST
Dave
It's a request to do below:
A request to rebase the package source code version from 2.0.13 to 2.0.14

and I don't know what's the RHEL6-Extras, but we will suggest to use 2.0.14 for current  RHEL 6.x version including 6.8 before we release the new version.
Comment 7 mingzhan 2015-12-22 10:46:14 EST
(In reply to Dave Anderson from comment #4)
> > Please review the package above, and confirm that it is what you would
> > expect for a RHEL6 rebase.
> 
> In addition, the Fedora package referenced above would require these changes:
> 
> (1) This line needs to be commented out from the WALinuxAgent.spec file:
> 
>     Requires:       ntfsprogs
> 
> (2) Presumably the patch from here would need to be applied:
> 
>     BZ #1291298 - [Feature Request]WALA- RHUI support for RHEL On-Demand
> Image in Azure
>     https://bugzilla.redhat.com/show_bug.cgi?id=1291298

Please ignore the item (2) in this request, I submitted the new feature in bug 1291303 with targeting a new WALA release, not for 2.0.14.

Yue
Can you please confirm the item (1)?
Comment 8 mingzhan 2015-12-22 10:47:45 EST
(In reply to Dave Anderson from comment #3)
> The walinuxagent.spec file that is part of the github 2.0.14 release is
> unsuitable because it is missing several items that are part of the 
> current RHEL6 WALinuxAgent.spec file, which was originally derived
> from a 2.0.13-based Fedora package. 
> 
> I see that there is this Fedora package:
> 
>   Information for build WALinuxAgent-2.0.14-1.el6
>   http://koji.fedoraproject.org/koji/buildinfo?buildID=666562
> 
> Please review the package above, and confirm that it is what you would
> expect for a RHEL6 rebase.

Yue & Liz
Could you please help to answer this question from Dave?

Scott
Comment 9 Dave Anderson 2015-12-22 12:03:42 EST
(In reply to mingzhan from comment #7)

> > (2) Presumably the patch from here would need to be applied:
> > 
> >     BZ #1291298 - [Feature Request]WALA- RHUI support for RHEL On-Demand
> > Image in Azure
> >     https://bugzilla.redhat.com/show_bug.cgi?id=1291298
> 
> Please ignore the item (2) in this request, I submitted the new feature in
> bug 1291303 with targeting a new WALA release, not for 2.0.14.

I understand that, but when a rebase is done, typically patches to
the superseded version would be discarded, because they normally would
be included in the rebased version.

So, please clarify whether the patch in BZ #1291298 should be carried
forward into this 2.0.14 rebase.
Comment 10 Dave Anderson 2015-12-22 12:17:59 EST
(In reply to mingzhan from comment #7)

> > In addition, the Fedora package referenced above would require these changes:
> > 
> > (1) This line needs to be commented out from the WALinuxAgent.spec file:
> > 
> >     Requires:       ntfsprogs
 
> Yue
> Can you please confirm the item (1)?

There is no ntfsprogs in the RHEL7 distribution so it was explicitly
commented out in the RHEL7 package.

And when I tried to build the 2.0.14 package in a new RHEL6 environment,
the build failed, due to the fact that there was no ntfsprogs package 
available.  I'm not sure why that happened, but maybe the package has
been removed from RHEL6?   

But anyway, since the package is unnecessary in RHEL7, it would be preferable
(and perhaps mandatory) to do the same thing in RHEL6.
Comment 11 mingzhan 2015-12-23 04:35:44 EST
(In reply to Dave Anderson from comment #3)
> The walinuxagent.spec file that is part of the github 2.0.14 release is
> unsuitable because it is missing several items that are part of the 
> current RHEL6 WALinuxAgent.spec file, which was originally derived
> from a 2.0.13-based Fedora package. 
> 
> I see that there is this Fedora package:
> 
>   Information for build WALinuxAgent-2.0.14-1.el6
>   http://koji.fedoraproject.org/koji/buildinfo?buildID=666562
> 
> Please review the package above, and confirm that it is what you would
> expect for a RHEL6 rebase.

Dave
We will suggest to use the same systemd requirements from Fedora package for WALA 2.0.14 in RHEL.

Scott
Comment 12 Dave Anderson 2016-01-07 10:21:03 EST
Superseded by:

  Bug 1296360 - [WALA]Request to package WALA 2.0.16 into RHEL 6 Repo
  https://bugzilla.redhat.com/show_bug.cgi?id=1296360

Note You need to log in before you can comment on or make changes to this bug.