Bug 1291619 - [WALA]Request to package WALA 2.0.14 into RHEL 7 Repo
[WALA]Request to package WALA 2.0.14 into RHEL 7 Repo
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: WALinuxAgent (Show other bugs)
7.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Dave Anderson
: Rebase
Depends On:
Blocks: 1295826 1296180
  Show dependency treegraph
 
Reported: 2015-12-15 05:05 EST by mingzhan
Modified: 2016-02-09 10:01 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: 1291616
Environment:
Last Closed: 2016-01-07 10:20:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mingzhan 2015-12-15 05:05:19 EST
+++ This bug was initially created as a clone of Bug #1291616 +++

Description of Request:
Request to package WALA 2.0.14 into REHL 7 Repo

Version-Release number of selected component (if applicable):
https://github.com/Azure/WALinuxAgent/releases/tag/WALinuxAgent-2.0.14

Impact:
2.0.14 has the hot fix for below critical bug:
Provision failure (higher rate in large size VM). 

If no 2.0.14, customer will have opportunity to hit this issue.
Comment 2 Dave Anderson 2015-12-15 10:01:23 EST
Please clarify this bugzilla.  There appear to be two separate requests:

 (1) A request to move this package from RHEL7-Extras into RHEL7.3
 (2) A request to rebase the package source code version from 2.0.13 to 2.0.14

I that correct?
Comment 3 Dave Anderson 2015-12-15 12:12:47 EST
The walinuxagent.spec file that is part of the github 2.0.14 release is
unsuitable because it is missing several items that are part of the 
current RHEL7 WALinuxAgent.spec file (most notably all of the systemd
requirements), and which was originally derived from a 2.0.13-based 
Fedora package.  

I see that there is this Fedora package:

  Information for build WALinuxAgent-2.0.14-.el7
  http://koji.fedoraproject.org/koji/buildinfo?buildID=666561

Please review the package above, and confirm that it is what you would
expect for a RHEL7 rebase.
Comment 4 Dave Anderson 2015-12-15 14:51:34 EST
> Please review the package above, and confirm that it is what you would
> expect for a RHEL7 rebase.

In addition, the Fedora package referenced above would require these changes:

(1) This line needs to be commented out from the WALinuxAgent.spec file:

    Requires:       ntfsprogs

(2) Presumably the patch from here would need to be applied:

    BZ #1291303 - [Feature Request]WALA- RHUI support for RHEL On-Demand Image in Azure
    https://bugzilla.redhat.com/show_bug.cgi?id=1291303
Comment 5 Dave Anderson 2015-12-18 11:29:18 EST
Please respond to comments #2, #3 and #4.
Comment 6 mingzhan 2015-12-22 09:42:01 EST
Dave
It's a request to do below:
A request to rebase the package source code version from 2.0.13 to 2.0.14
Comment 7 mingzhan 2015-12-22 10:45:39 EST
(In reply to Dave Anderson from comment #4)
> > Please review the package above, and confirm that it is what you would
> > expect for a RHEL7 rebase.
> 
> In addition, the Fedora package referenced above would require these changes:
> 
> (1) This line needs to be commented out from the WALinuxAgent.spec file:
> 
>     Requires:       ntfsprogs
> 
> (2) Presumably the patch from here would need to be applied:
> 
>     BZ #1291303 - [Feature Request]WALA- RHUI support for RHEL On-Demand
> Image in Azure
>     https://bugzilla.redhat.com/show_bug.cgi?id=1291303

Please ignore the item (2) in this request, I submitted the new feature in bug 1291303 with targeting a new WALA release, not for  2.0.14.

Yue
Can you please confirm the item (1)?
Comment 8 mingzhan 2015-12-22 10:48:29 EST
(In reply to Dave Anderson from comment #3)
> The walinuxagent.spec file that is part of the github 2.0.14 release is
> unsuitable because it is missing several items that are part of the 
> current RHEL7 WALinuxAgent.spec file (most notably all of the systemd
> requirements), and which was originally derived from a 2.0.13-based 
> Fedora package.  
> 
> I see that there is this Fedora package:
> 
>   Information for build WALinuxAgent-2.0.14-.el7
>   http://koji.fedoraproject.org/koji/buildinfo?buildID=666561
> 
> Please review the package above, and confirm that it is what you would
> expect for a RHEL7 rebase.

Yue & Liz
Could you please help to answer this question from Dave?

Scott
Comment 9 Dave Anderson 2015-12-22 12:03:35 EST
(In reply to mingzhan from comment #7)
> > (2) Presumably the patch from here would need to be applied:
> > 
> >     BZ #1291303 - [Feature Request]WALA- RHUI support for RHEL On-Demand
> > Image in Azure
> >     https://bugzilla.redhat.com/show_bug.cgi?id=1291303
> 
> Please ignore the item (2) in this request, I submitted the new feature in
> bug 1291303 with targeting a new WALA release, not for  2.0.14.

I understand that, but when a rebase is done, typically patches to
the superseded version would be discarded, because they normally would
be included in the rebased version.

So, please clarify whether the patch in BZ #1291303 should be carried
forward into this 2.0.14 rebase.
Comment 10 Dave Anderson 2015-12-22 12:12:42 EST
(In reply to mingzhan from comment #7)
> > In addition, the Fedora package referenced above would require these changes:
> > 
> > (1) This line needs to be commented out from the WALinuxAgent.spec file:
> > 
> >     Requires:       ntfsprogs
> > 

> Yue
> Can you please confirm the item (1)?

There is no ntfsprogs package in RHEL7, so there is no choice but to
comment it out as was done for the RHEL7 2.0.13 version.
Comment 11 Yue Zhang 2015-12-23 00:57:49 EST
(In reply to Dave Anderson from comment #10)
> (In reply to mingzhan from comment #7)
> > > In addition, the Fedora package referenced above would require these changes:
> > > 
> > > (1) This line needs to be commented out from the WALinuxAgent.spec file:
> > > 
> > >     Requires:       ntfsprogs
> > > 
> 
> > Yue
> > Can you please confirm the item (1)?
> 
> There is no ntfsprogs package in RHEL7, so there is no choice but to
> comment it out as was done for the RHEL7 2.0.13 version.

Please remove the dependency on ntfsprogs. That is not used by WALinuxAgent.
Comment 12 mingzhan 2015-12-23 04:24:48 EST
(In reply to Dave Anderson from comment #9)
> (In reply to mingzhan from comment #7)
> > > (2) Presumably the patch from here would need to be applied:
> > > 
> > >     BZ #1291303 - [Feature Request]WALA- RHUI support for RHEL On-Demand
> > > Image in Azure
> > >     https://bugzilla.redhat.com/show_bug.cgi?id=1291303
> > 
> > Please ignore the item (2) in this request, I submitted the new feature in
> > bug 1291303 with targeting a new WALA release, not for  2.0.14.
> 
> I understand that, but when a rebase is done, typically patches to
> the superseded version would be discarded, because they normally would
> be included in the rebased version.
> 
> So, please clarify whether the patch in BZ #1291303 should be carried
> forward into this 2.0.14 rebase.

Please do NOT apply this patch into 2.0.14,it's still part of code under full test. I pasted into the feature request just better understanding of this feature.
Comment 13 mingzhan 2015-12-23 04:35:25 EST
(In reply to Dave Anderson from comment #3)
> The walinuxagent.spec file that is part of the github 2.0.14 release is
> unsuitable because it is missing several items that are part of the 
> current RHEL7 WALinuxAgent.spec file (most notably all of the systemd
> requirements), and which was originally derived from a 2.0.13-based 
> Fedora package.  
> 
> I see that there is this Fedora package:
> 
>   Information for build WALinuxAgent-2.0.14-.el7
>   http://koji.fedoraproject.org/koji/buildinfo?buildID=666561
> 
> Please review the package above, and confirm that it is what you would
> expect for a RHEL7 rebase.

Dave
We will suggest to use the same systemd requirements from Fedora package for WALA 2.0.14 in RHEL.

Scott
Comment 14 Dave Anderson 2015-12-23 11:54:20 EST
(In reply to mingzhan from comment #12)
> (In reply to Dave Anderson from comment #9)
> > (In reply to mingzhan from comment #7)
> > > > (2) Presumably the patch from here would need to be applied:
> > > > 
> > > >     BZ #1291303 - [Feature Request]WALA- RHUI support for RHEL On-Demand
> > > > Image in Azure
> > > >     https://bugzilla.redhat.com/show_bug.cgi?id=1291303
> > > 
> > > Please ignore the item (2) in this request, I submitted the new feature in
> > > bug 1291303 with targeting a new WALA release, not for  2.0.14.
> > 
> > I understand that, but when a rebase is done, typically patches to
> > the superseded version would be discarded, because they normally would
> > be included in the rebased version.
> > 
> > So, please clarify whether the patch in BZ #1291303 should be carried
> > forward into this 2.0.14 rebase.
> 
> Please do NOT apply this patch into 2.0.14,it's still part of code under
> full test. I pasted into the feature request just better understanding of
> this feature.

OK, so should BZ #1291303 be closed?  It makes no sense for it to exist 
since this rebase to 2.0.14 will supersede any changes to what will become
an obsolete version based upon 2.0.13.
Comment 15 Dave Anderson 2016-01-07 10:20:58 EST
Superseded by:

  Bug 1296359 - [WALA]Request to package WALA 2.0.16 into RHEL 7 Repo
  https://bugzilla.redhat.com/show_bug.cgi?id=1296359

Note You need to log in before you can comment on or make changes to this bug.