Bug 1291629 - Hidden file found: /etc/.updated: ASCII text
Hidden file found: /etc/.updated: ASCII text
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: rkhunter (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mukundan Ragavan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 05:32 EST by Nerijus Baliūnas
Modified: 2016-01-23 20:06 EST (History)
4 users (show)

See Also:
Fixed In Version: rkhunter-1.4.2-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-23 20:06:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nerijus Baliūnas 2015-12-15 05:32:54 EST
After CentOS 7.1->7.2 upgrade there is a new warning:
Warning: Hidden file found: /etc/.updated: ASCII text

Fedora /etc/rkhunter.conf already has 
ALLOWHIDDENFILE=/etc/.updated

See bug 1288450
Comment 1 Mukundan Ragavan 2015-12-15 06:31:06 EST
Fair enough. I will push an update after taking a look.

Thanks for reporting this.
Comment 2 Mukundan Ragavan 2015-12-21 21:56:53 EST
Here is *a* scratch build to take a look at this.

https://koji.fedoraproject.org/koji/taskinfo?taskID=12276725


Please be advised that I have just merged the the fedora config patch with epel7 branch. I am going through the configs to make sure that they match EL7 as well. If you can test as well and report back,I will build it "officially" and submit an update.
Comment 3 Nerijus Baliūnas 2015-12-22 05:58:57 EST
I get no more warning about hidden files and directories, but I get a new one:
  Checking if SSH root access is allowed          [ Warning ]
Warning: The SSH configuration option 'PermitRootLogin' has not been set.
The default value may be 'yes', to allow root access.

It seems the first change is not needed:
--- rkhunter.conf.!	2014-10-27 17:54:24.000000000 +0200
+++ rkhunter.conf	2015-12-22 04:53:35.000000000 +0200
@@ -307,7 +307,7 @@
 # The default value is 'no'.
 #
 #ALLOW_SSH_ROOT_USER=no
-ALLOW_SSH_ROOT_USER=unset
+ALLOW_SSH_ROOT_USER=yes
 
 #
 # Set this option to '1' to allow the use of the SSH-1 protocol, but note
Comment 4 Mukundan Ragavan 2015-12-22 20:36:16 EST
ok cool! I saw ssh value only as well. I will push this as update after correcting for ssh.

Thanks for testing.
Comment 5 Fedora Update System 2015-12-31 19:29:59 EST
rkhunter-1.4.2-6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-18897f65c0
Comment 6 Fedora Update System 2016-01-02 21:51:26 EST
rkhunter-1.4.2-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-18897f65c0
Comment 7 Nerijus Baliūnas 2016-01-05 03:00:37 EST
Unfortunately instead of adding back "ALLOW_SSH_ROOT_USER=unset" as I wrote in Comment 3 rkhunter-1.4.2-6.el7 has no ALLOW_SSH_ROOT_USER at all. Because of this I get this warning:

Warning: The SSH configuration option 'PermitRootLogin' has not been set.
         The default value may be 'yes', to allow root access.

Could you please put back ALLOW_SSH_ROOT_USER=unset to rkhunter.conf?
Comment 8 Mukundan Ragavan 2016-01-05 18:39:55 EST
Rats! My apologies. :(

Will be fixed and updated tonight ...
Comment 9 Fedora Update System 2016-01-05 22:33:21 EST
rkhunter-1.4.2-7.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-18897f65c0
Comment 10 Fedora Update System 2016-01-06 22:51:28 EST
rkhunter-1.4.2-7.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-18897f65c0
Comment 11 Fedora Update System 2016-01-23 20:06:09 EST
rkhunter-1.4.2-7.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.