Bug 1291669 - jobs.started_on is always empty
jobs.started_on is always empty
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.6.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Hui Song
Einat Pacifici
container
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 07:21 EST by Mooli Tayer
Modified: 2016-09-19 13:13 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-19 13:13:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Start time showing in Tasks. (72.93 KB, image/png)
2016-07-31 06:29 EDT, Einat Pacifici
no flags Details

  None (edit)
Description Mooli Tayer 2015-12-15 07:21:51 EST
Description of problem:
In both scan jobs (vm scan / container scan) started_on is always empty 

Version-Release number of selected component (if applicable):
5.5

How reproducible:
100% As far as I can tell

Steps to Reproduce:
1. execute a vm scan job / container scan job
2. go to configure -> tasks -> 'all vm analysis tasks' OR check the DB table 'jobs' 


Actual results:
- Started ui column is always displayed empty
- DB:jobs.started_on is always empty 

Expected results:
started_on should container job start time.

Additional info:
github issue: https://github.com/ManageIQ/manageiq/issues/5659
Comment 3 Mooli Tayer 2016-04-12 05:19:09 EDT
Sorry for not responding sooner. 
I tried to reproduce every now and then but was unable to run a vm scan. Following input from Hui this might be relevant only to container scan
Comment 4 Federico Simoncelli 2016-07-13 03:36:03 EDT
Mooli, now that we use the dispatcher, is this fixed?

do_dispatch and assign_proxy_to_job should set started_on.
Comment 5 Mooli Tayer 2016-07-13 09:16:38 EDT
Yes it is resolved on master. 
Moving to on qa since I beleive they should have the fix already.
Please correct if that is wrong.
Comment 6 Einat Pacifici 2016-07-31 06:29 EDT
Created attachment 1186005 [details]
Start time showing in Tasks.

Verified. When running Perform Smart State analysis" then, Tasks -- All VM Analysis Tasks shows start time.

Note You need to log in before you can comment on or make changes to this bug.