Bug 1291690 - hammer import refers to an internal name
hammer import refers to an internal name
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.1.3
Unspecified Unspecified
unspecified Severity low (vote)
: Beta
: --
Assigned To: David O'Brien
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 07:56 EST by David O'Brien
Modified: 2016-07-27 07:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: hammer-cli-import-0.10.23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:08:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David O'Brien 2015-12-15 07:56:33 EST
Description of problem:

# hammer import all --delete --help

--directory DIR_PATH          stargate-export directory
   Default: "/tmp/exports"

Version-Release number of selected component (if applicable):
6.1.3

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment from ggainey:

"no, that was an internal name.  "Place where Satellite 5 export file was unzipped" is what that is."
Comment 1 David O'Brien 2015-12-15 08:37:36 EST
Created PR:

https://github.com/Katello/hammer-cli-import/pull/24
Comment 7 Grant Gainey 2016-01-25 14:35:12 EST
hammer-cli-import.github: f2c0ef06ea8883d1573c483495328afbdf808b0d
Comment 9 Og Maciel 2016-03-24 16:28:58 EDT
hammer> import all --delete --help
Usage:
     import all [OPTIONS]

Options:
 --debug                       Turn on debugging-information
                               Default: false
 --delete                      Delete entities instead of importing them
                               Default: false
 --directory DIR_PATH          The directory where the export file was extracted
                               Default: "/tmp/exports"
 --dry-run                     Show what we would have done, if we'd been allowed
                               Default: false
 --entities entity[,entity...] Import specific entities
                               Default: "all"
 --into-org-id ORG_ID          Import all organizations into one specified by id
 --list-entities               List entities we understand
                               Default: false
 --logfile LOGFILE             Where output is logged to
                               Default: "/root/import.log"
 --macro_mapping FILE          Mapping of Satellite-5 config-file-macros to puppet facts
 --manifest-directory DIR_PATH Directory holding manifests
 --merge-users                 Merge pre-created users (except admin)
                               Default: false
 --no-async                    Wait for async tasks in foreground
                               Default: false
 --quiet                       Be silent - no output to STDOUT
                               Default: false
 --synchronize                 Synchronize imported repositories
                               Default: false
 --verbose                     Be noisy - everything goes to STDOUT and to a logfile
                               Default: false
 --wait                        Wait for repository synchronization to finish
                               Default: false
 -h, --help                    print help
Comment 10 Og Maciel 2016-03-24 16:29:52 EDT
This looks good to me now, so I am closing as VERIFIED as per my last comment (Satellite 6.2.0 SNAP 5.1)
Comment 13 Bryan Kearney 2016-07-27 07:08:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.