Bug 1291703 - when importing from export domain UI fails with classcast exception.
when importing from export domain UI fails with classcast exception.
Status: CLOSED DUPLICATE of bug 1289037
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.1
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Allon Mureinik
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 08:21 EST by Martin Mucha
Modified: 2016-03-10 02:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 10:27:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Martin Mucha 2015-12-15 08:21:45 EST
Description of problem:
when importing from export domain UI fails with classcast exception.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. clean installation
2. create host, storage domain, export domain, vm with 3 nics
3. export vm to export domain
4. storage->export-domain->import vm->import

dialog opens, but following exception is thrown as well:

java.lang.ClassCastException: org.ovirt.engine.core.common.businessentities.StorageDomain cannot be cast to org.ovirt.engine.core.common.businessentities.storage.Disk 	at org.ovirt.engine.ui.common.widget.uicommon.disks.DisksViewColumns$9.getValue(DisksViewColumns.java:1) 	at com.google.gwt.user.cellview.client.Column.render(Column.java:165) 	at com.google.gwt.user.cellview.client.AbstractCellTableBuilder.renderCell(AbstractCellTableBuilder.java:206) 	at com.google.gwt.user.cellview.client.DefaultCellTableBuilder.buildRowImpl(DefaultCellTableBuilder.java:129) 	at com.google.gwt.user.cellview.client.AbstractCellTableBuilder.buildRow(AbstractCellTableBuilder.java:87) 	at com.google.gwt.user.cellview.client.AbstractCellTable.buildRowValues(AbstractCellTable.java:2352) 	at com.google.gwt.user.cellview.client.AbstractCellTable.replaceAllChildren(AbstractCellTable.java:2154) 	at com.google.gwt.user.cellview.client.AbstractHasData$View.replaceAllChildren(AbstractHasData.java:245) 	at com.google.gwt.user.cellview.client.HasDataPresenter.resolvePendingState(HasDataPresenter.java:1351) 	at com.google.gwt.user.cellview.client.HasDataPresenter.access$3(HasDataPresenter.java:1062) 	at com.google.gwt.user.cellview.client.HasDataPresenter$2.execute(HasDataPresenter.java:984) 	at com.google.gwt.core.client.impl.SchedulerImpl$Task$.executeScheduled$(SchedulerImpl.java:50) 	at com.google.gwt.core.client.impl.SchedulerImpl.runScheduledTasks(SchedulerImpl.java:180) 	at com.google.gwt.core.client.impl.SchedulerImpl.flushFinallyCommands(SchedulerImpl.java:277) 	at com.google.gwt.core.client.impl.Impl.exit(Impl.java:380)

Actual results:


Expected results:


Additional info:
Comment 2 Martin Mucha 2015-12-16 07:38:40 EST
hash: 81deade7478d1f1b55fd5cbc80a3b3003d9d1a18
Comment 3 Dan Kenigsberg 2015-12-16 10:27:01 EST

*** This bug has been marked as a duplicate of bug 1289037 ***

Note You need to log in before you can comment on or make changes to this bug.