Bug 1291750 - Discovery ramdisk fails to build - curl times out retrieving delorean-rdo-management.repo repos.
Discovery ramdisk fails to build - curl times out retrieving delorean-rdo-man...
Status: CLOSED DUPLICATE of bug 1288648
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer (Show other bugs)
7.0 (Kilo)
x86_64 Linux
unspecified Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Mike Burns
Omri Hochman
: Field
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 09:40 EST by Adam McLean
Modified: 2016-05-29 19:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 09:49:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam McLean 2015-12-15 09:40:21 EST
Description of problem:
The discovery ramdisk is failing to build when issuing commands:
openstack overcloud image build --type discovery-ramdisk

Version-Release number of selected component (if applicable):

[stack@undercloud bin]$ rpm -qa | grep rhos
rhos-release-1.0.22-1.noarch

[stack@undercloud bin]$ rpm -qa | grep osc
python-rdomanager-oscplugin-0.0.10-8.el7ost.noarch

[stack@undercloud bin]$ rpm -qa | grep heat
openstack-heat-api-2015.1.1-5.el7ost.noarch
python-heatclient-0.6.0-1.el7ost.noarch
openstack-heat-common-2015.1.1-5.el7ost.noarch
openstack-heat-api-cfn-2015.1.1-5.el7ost.noarch
openstack-heat-api-cloudwatch-2015.1.1-5.el7ost.noarch
heat-cfntools-1.2.8-2.el7.noarch
openstack-heat-templates-0-0.6.20150605git.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-71.el7ost.noarch
openstack-heat-engine-2015.1.1-5.el7ost.noarch

rhos commands used:
rhos-release -p Y1 7-director
rhos-release -p Z2 7


How reproducible:
100%

Steps to Reproduce:
1. 
Configure environment variables as following:
export NODE_DIST=rhel7
export DIB_LOCAL_IMAGE=rhel7-guest.qcow2
export USE_DELOREAN_TRUNK=0
export RHOS=1
export DIB_YUM_REPO_CONF="/etc/yum.repos.d/rhos-release-7-director.repo /etc/yum.repos.d/rhos-release-7.repo /etc/yum.repos.d/rhos-release-rhel-7.1.repo"

2.
Execute build command:
openstack overcloud image build --type discovery-ramdisk

Actual results:
This will time out while trying to retrieve data from upstream RDO:
+ sudo -E curl -o /etc/yum.repos.d/delorean-rdo-management.repo http://trunk-mgt.rdoproject.org/centos-kilo/current-passed-ci/delorean-rdo-management.repo

ramdisk image will not build.

Expected results:
Ramdisk would build!

Additional info:
If you edit the file:
/usr/share/instack-undercloud/delorean-rdo-management/pre-install.d/00-delorean-rdo-management

And comment everything out, the ramdisk will build.

So it appears that 'export USE_DELOREAN_TRUNK=0' is not being respected by the build process.
Comment 2 Mike Burns 2015-12-15 09:49:30 EST

*** This bug has been marked as a duplicate of bug 1288648 ***

Note You need to log in before you can comment on or make changes to this bug.