This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1291968 - INVALID MAC when provision from Satellite
INVALID MAC when provision from Satellite
Status: CLOSED DEFERRED
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.1.5
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 00:09 EST by jnikolak
Modified: 2017-03-23 15:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-23 15:51:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jnikolak 2015-12-16 00:09:37 EST
When trying to provision, 

I'm getting error:
INVALID MAC

However the issue is, that when provisioning via compute resource it shouldn't ask for a mac

2015-12-16 14:56:34 [I] Authorized user admin(Admin User)
2015-12-16 14:56:35 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/foreman-tasks-0.6.15.7/app/views/foreman_tasks/api/tasks/show.json.rabl (26.6ms)
2015-12-16 14:56:35 [I] Completed 200 OK in 64ms (Views: 27.0ms | ActiveRecord: 6.2ms)
2015-12-16 14:56:35 [I] Processing by HostsController#create as */*
2015-12-16 14:56:35 [I]   Parameters: {"utf8"=>"✓", "authenticity_token"=>"8bCaqnHeXkYjZS0tP42M+KtNsVOghiELEHnbpQYBs+0=", "host"=>{"name"=>"invalidmac", "organization_id"=>"4", "location_id"=>"3", "hostgroup_id"=>"3", "compute_resource_id"=>"1", "lifecycle_environment_id"=>"2", "content_view_id"=>"9", "environment_id"=>"9", "content_source_id"=>"1", "puppet_ca_proxy_id"=>"1", "puppet_proxy_id"=>"1", "puppetclass_ids"=>[""], "managed"=>"true", "progress_report_id"=>"[FILTERED]", "type"=>"Host::Managed", "compute_attributes"=>{"cluster"=>"5c82a57e-ab50-4dc2-95cb-97003330d73c", "template"=>"", "cores"=>"1", "memory"=>"268435456", "interfaces_attributes"=>{"new_interfaces"=>{"name"=>"", "network"=>"49590203-8812-491b-a1fa-3834808431bf", "_delete"=>""}}, "volumes_attributes"=>{"new_volumes"=>{"size_gb"=>"", "storage_domain"=>"c35e9555-795a-4e68-840a-8f4f0e934312", "_delete"=>"", "id"=>"", "preallocate"=>"0"}}, "start"=>"1"}, "domain_id"=>"1", "realm_id"=>"", "mac"=>"", "subnet_id"=>"2", "ip"=>"10.66.222.7", "interfaces_attributes"=>{"new_interfaces"=>{"_destroy"=>"false", "type"=>"Nic::Managed", "mac"=>"", "identifier"=>"", "name"=>"", "domain_id"=>"", "subnet_id"=>"", "ip"=>"", "managed"=>"1", "virtual"=>"0", "tag"=>"", "attached_to"=>""}}, "architecture_id"=>"1", "operatingsystem_id"=>"1", "provision_method"=>"build", "build"=>"1", "medium_id"=>"7", "ptable_id"=>"7", "disk"=>"", "root_pass"=>"[FILTERED]", "is_owned_by"=>"3-Users", "enabled"=>"1", "comment"=>"", "overwrite"=>"true"}, "capabilities"=>"build image", "provider"=>"Ovirt"}
2015-12-16 14:56:36 [W] Operation FAILED: Invalid MAC 
2015-12-16 14:56:36 [I]   Rendered common/500.html.erb (7.3ms)
2015-12-16 14:56:36 [I] Completed 500 Internal Server Error in 1086ms (Views: 8.8ms | ActiveRecord: 10.1ms)
2015-12-16 14:56:37 [I] Processing by ForemanTasks::Api::TasksController#show as application/json;version=2
Comment 2 jnikolak 2016-01-13 04:55:31 EST
I may have located the error, its because I didn't have reverse dns working.
After switching dns servers, I'm now getting a different error.

Can you try to disable reverse dns to see if you get the same error?
Comment 3 jnikolak 2016-01-16 03:07:51 EST
This had to do with reversedns not working,  for some reason baremetal doesn't require reverse dns entries, but when provisioning via computer resources, this is required.

I confirmed this with alexey, we switched over the dns to another server but got the same error. The moment we added a reverse dns entry, the Invalid Mac error was gone. 

therefore can we add into this bug, better error detection for "invalid mac" as the errors generated don't give any indication to check reverse dns entries.
Comment 4 Bryan Kearney 2016-07-26 15:08:09 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 5 Bryan Kearney 2017-03-23 15:51:30 EDT
I do not believe this will be addressed in the next few releases, so I am closing this out. If you feel this was incorrect, please feel free to re-open with additional information.

Note You need to log in before you can comment on or make changes to this bug.