Bug 1292027 - Stopping pmcd takes a long time
Stopping pmcd takes a long time
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pcp (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nathan Scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 04:31 EST by Marko Myllynen
Modified: 2016-03-14 20:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 20:59:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2015-12-16 04:31:22 EST
Description of problem:
localhost:~# date ; time systemctl start pmcd.service ; date ;
Wed Dec 16 11:23:21 EET 2015
systemctl start pmcd.service  0.00s user 0.01s system 2% cpu 0.457 total
Wed Dec 16 11:23:22 EET 2015
localhost:~# date ; time systemctl stop pmcd.service ; date ;
Wed Dec 16 11:23:25 EET 2015
systemctl stop pmcd.service  0.01s user 0.01s system 0% cpu 3.349 total
Wed Dec 16 11:23:29 EET 2015
localhost:~# 

While 4 seconds might not sound like "a long time" it's actually more than half of the time spent when shutting down all the services running on a default Fedora installation.

IOW, after "poweroff" on Fedora the time to shutdown the system without pmcd is ~1-2 seconds. With pmcd in play the time is ~5-6 seconds.
Comment 1 Nathan Scott 2016-01-25 00:44:40 EST
There are two parts to the problem here, Marko.  The first aspect is pmcd itself taking quite a long time to shutdown, due to the way it waits on PMDAs at termination time.  Lukas and I ended up tackling this recently, in another context (some pmdaroot(1) work).

The second aspect is some overly-long delays in the rc script - I've got a fix and have been testing these (there's sporadic QA fallout), so it might make it for pcp-3.11.0, might not (certainly 3.11.1 otherwise).
Comment 2 Nathan Scott 2016-03-14 20:59:03 EDT
This was all tackled in pcp-3.11.0

Note You need to log in before you can comment on or make changes to this bug.