Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1292028 - packstack installation fails - ERROR : Error appeared during Puppet run: 172.16.32.20_neutron.pp
packstack installation fails - ERROR : Error appeared during Puppet run: 172....
Status: CLOSED DUPLICATE of bug 1296603
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Ivan Chavero
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 04:37 EST by Ariel Opincaru
Modified: 2016-04-18 02:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-18 12:18:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Installation logs (3.19 KB, application/x-gzip)
2015-12-16 04:37 EST, Ariel Opincaru
no flags Details

  None (edit)
Description Ariel Opincaru 2015-12-16 04:37:28 EST
Created attachment 1106343 [details]
Installation logs

Description of problem:
rhos 8 packstack installation fails.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
packstack installation should pass

Expected results:
packstack installation failed

Additional info:
rhos-release 8 -p 2015-12-11.6

output from packstack installation:
The installation log file is available at: /var/tmp/packstack/20151216-023245-TmSxOZ/openstack-setup.log

Installing:
Clean Up                                             [ DONE ]
Discovering ip protocol version                      [ DONE ]
Setting up ssh keys                                  [ DONE ]
Preparing servers                                    [ DONE ]
Pre installing Puppet and discovering hosts' details [ DONE ]
Adding pre install manifest entries                  [ DONE ]
Setting up CACERT                                    [ DONE ]
Adding AMQP manifest entries                         [ DONE ]
Adding MariaDB manifest entries                      [ DONE ]
Fixing Keystone LDAP config parameters to be undef if empty[ DONE ]
Adding Keystone manifest entries                     [ DONE ]
Adding Glance Keystone manifest entries              [ DONE ]
Adding Glance manifest entries                       [ DONE ]
Adding Cinder Keystone manifest entries              [ DONE ]
Checking if the Cinder server has a cinder-volumes vg[ DONE ]
Adding Cinder manifest entries                       [ DONE ]
Adding Nova API manifest entries                     [ DONE ]
Adding Nova Keystone manifest entries                [ DONE ]
Adding Nova Cert manifest entries                    [ DONE ]
Adding Nova Conductor manifest entries               [ DONE ]
Creating ssh keys for Nova migration                 [ DONE ]
Gathering ssh host keys for Nova migration           [ DONE ]
Adding Nova Compute manifest entries                 [ DONE ]
Adding Nova Scheduler manifest entries               [ DONE ]
Adding Nova VNC Proxy manifest entries               [ DONE ]
Adding OpenStack Network-related Nova manifest entries[ DONE ]
Adding Nova Common manifest entries                  [ DONE ]
Adding Neutron VPNaaS Agent manifest entries         [ DONE ]
Adding Neutron FWaaS Agent manifest entries          [ DONE ]
Adding Neutron LBaaS Agent manifest entries          [ DONE ]
Adding Neutron API manifest entries                  [ DONE ]
Adding Neutron Keystone manifest entries             [ DONE ]
Adding Neutron L3 manifest entries                   [ DONE ]
Adding Neutron L2 Agent manifest entries             [ DONE ]
Adding Neutron DHCP Agent manifest entries           [ DONE ]
Adding Neutron Metering Agent manifest entries       [ DONE ]
Adding Neutron Metadata Agent manifest entries       [ DONE ]
Adding Neutron SR-IOV Switch Agent manifest entries  [ DONE ]
Checking if NetworkManager is enabled and running    [ DONE ]
Adding OpenStack Client manifest entries             [ DONE ]
Adding Horizon manifest entries                      [ DONE ]
Adding Swift Keystone manifest entries               [ DONE ]
Adding Swift builder manifest entries                [ DONE ]
Adding Swift proxy manifest entries                  [ DONE ]
Adding Swift storage manifest entries                [ DONE ]
Adding Swift common manifest entries                 [ DONE ]
Adding Heat manifest entries                         [ DONE ]
Adding Heat CloudFormation API manifest entries      [ DONE ]
Adding MongoDB manifest entries                      [ DONE ]
Adding Redis manifest entries                        [ DONE ]
Adding Ceilometer manifest entries                   [ DONE ]
Adding Ceilometer Keystone manifest entries          [ DONE ]
Adding post install manifest entries                 [ DONE ]
Copying Puppet modules and manifests                 [ DONE ]
Applying 172.16.32.19_prescript.pp
Applying 172.16.32.18_prescript.pp
Applying 172.16.32.17_prescript.pp
Applying 172.16.32.20_prescript.pp
172.16.32.19_prescript.pp:                           [ DONE ]
172.16.32.17_prescript.pp:                           [ DONE ]
172.16.32.18_prescript.pp:                           [ DONE ]
172.16.32.20_prescript.pp:                           [ DONE ]
Applying 172.16.32.18_amqp.pp
Applying 172.16.32.18_mariadb.pp
172.16.32.18_amqp.pp:                                [ DONE ]
172.16.32.18_mariadb.pp:                             [ DONE ]
Applying 172.16.32.18_keystone.pp
Applying 172.16.32.18_glance.pp
Applying 172.16.32.18_cinder.pp
172.16.32.18_keystone.pp:                            [ DONE ]
172.16.32.18_glance.pp:                              [ DONE ]
172.16.32.18_cinder.pp:                              [ DONE ]
Applying 172.16.32.18_api_nova.pp
172.16.32.18_api_nova.pp:                            [ DONE ]
Applying 172.16.32.18_nova.pp
Applying 172.16.32.19_nova.pp
Applying 172.16.32.17_nova.pp
Applying 172.16.32.20_neutron.pp
172.16.32.20_neutron.pp:                          [ ERROR ]
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 172.16.32.20_neutron.pp
Error: invalid value for Integer(): "" at /var/tmp/packstack/3bc04368eed94af2b958a2082cd930de/modules/neutron/manifests/agents/ml2/ovs.pp:207 on node d31zc-aopincar-rh-pud-pksk-network.novalocal
You will find full trace in log /var/tmp/packstack/20151216-023245-TmSxOZ/manifests/172.16.32.20_neutron.pp.log
Please check log file /var/tmp/packstack/20151216-023245-TmSxOZ/openstack-setup.log for more information
Additional information:
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * Warning: NetworkManager is active on 172.16.32.19, 172.16.32.18, 172.16.32.17, 172.16.32.20. OpenStack networking currently does not work on systems that have the Network Manager service enabled.
 * File /root/keystonerc_admin has been created on OpenStack client host 172.16.32.18. To use the command line tools you need to source the file.
 * To access the OpenStack Dashboard browse to http://172.16.32.18/dashboard .
Please, find your login credentials stored in the keystonerc_admin in your home directory.

cmd: packstack --answer-file=/root/packstack_config.txt && touch /root/packstack-already-done
Comment 2 Ivan Chavero 2016-01-18 12:18:54 EST

*** This bug has been marked as a duplicate of bug 1296603 ***

Note You need to log in before you can comment on or make changes to this bug.