Bug 1292068 - [engine-webadmin] 'Use host' is not refreshed while navigating between DCs in the add storage prompt
[engine-webadmin] 'Use host' is not refreshed while navigating between DCs in...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.1.3
x86_64 Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.2
: 3.6.2.5
Assigned To: Tal Nisan
Elad
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 06:59 EST by Elad
Modified: 2016-02-18 06:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:18:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
tnisan: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
Screenshots and engine.log (554.65 KB, application/x-gzip)
2015-12-16 06:59 EST, Elad
no flags Details

  None (edit)
Description Elad 2015-12-16 06:59:49 EST
Created attachment 1106384 [details]
Screenshots and engine.log

Version-Release number of selected component (if applicable):
rhevm-3.6.1.3-0.1.el6.noarch
rhevm-webadmin-portal-3.6.1.3-0.1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Have 2 DCs: one with an active host and second without any.
2. Navigate to 'Storage' main tab, click on 'Add'
3. Pick the DC where there is an active host. Check 'Use host', a host will appear.
4. Change DC to 'none'. The active host appears as expected.
5. Pick the DC where there are no active hosts. Check 'Use host', no hosts appear as expected. 
6. Change DC to 'none' once again


Actual results:
no hosts appear after step 6 in the 'Use host' scroll menu. This seems to happen since this scroll menu is not refreshed when navigating between a DC with no active host and 'none' DC.

Expected results:
The 'Use host' scroll menu should be refreshed while navigating between DCs.

Additional info:
Screenshots and engine.log
Screenshots are numbered according to steps to reproduce
Comment 1 Tal Nisan 2015-12-30 07:27:20 EST
Tried to follow the steps to reproduce and some more ways to reproduce but could not, following the flow in the code it seems that the host is updated upon every change in the data center so I reckon the issue was fixed somewhere along the way between the versions, moving to modified so it can be verified
Comment 2 Elad 2016-01-14 07:39:25 EST
(In reply to Tal Nisan from comment #1)
> Tried to follow the steps to reproduce and some more ways to reproduce but
> could not, following the flow in the code it seems that the host is updated
> upon every change in the data center so I reckon the issue was fixed
> somewhere along the way between the versions, moving to modified so it can
> be verified

Indeed. Moving to verified, marking as testOnly.

Verified using:
rhevm-3.6.2.5-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.