Bug 1292140 - [RFE] Virt-who support for Citrix XenServer
[RFE] Virt-who support for Citrix XenServer
Status: CLOSED DUPLICATE of bug 1272575
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Radek Novacek
Eko
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 10:00 EST by Adi Akbar
Modified: 2016-11-30 19:34 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-12 14:08:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Citrix Xenserver support for Virt-Who (11.87 KB, patch)
2016-02-04 11:07 EST, Martin Juhl
no flags Details | Diff

  None (edit)
Description Adi Akbar 2015-12-16 10:00:38 EST
FEATURE REQUEST
---------------

1. Proposed title of this feature request  

-- Virt-who support for Citrix XenServer
      
2. Who is the customer behind the request?  

Account:  Martin Juhl, acc # 5615262
  
TAM customer: no 
SRM customer: no
Strategic: no  
      
3. What is the nature and description of the request?  

-- Customer is requesting for Citrix XenServer support in Virt-who.
      
4. Why does the customer need this? (List the business requirements here)  

-- Customer wants to know as to why the XenServer is not a supported hypervisor yet and is requesting us to enhance virt-who to be able to pull subscription information from XenServer. Customer has got quite a lot of clients running on XenServer, and they might lose some of these customers if they do not support XenServer.
      
5. How would the customer like to achieve this? (List the functional requirements here)  

-- Customer wants the feature with virt-who.
      
6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  

-- With the help of virt-who configuration.
      
7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  

-- No
      
8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  

-- This is generic to all supported RHEL versions.
      
9. Is the sales team involved in this request and do they have any additional input?  

-- No
      
10. List any affected packages or components.  

-- virt-who
      
11. Would the customer be able to assist in testing this functionality if implemented?  

-- Yes

-----------------------------------------------------------------------------------------
Comment 2 Chris Williams 2016-01-12 14:08:26 EST

*** This bug has been marked as a duplicate of bug 1272575 ***
Comment 3 Martin Juhl 2016-02-04 11:07 EST
Created attachment 1121132 [details]
Citrix Xenserver support for Virt-Who

Patch with Citrix Xenserver support included.. Could we please add this to the officiel packages????

It also need the python XenAPI ( https://pypi.python.org/pypi/XenAPI) to be packaged.... but that should be pretty straight forward....
Comment 4 Radek Novacek 2016-02-04 11:12:58 EST
There is already xenserver support in the upstream repository:

https://github.com/virt-who/virt-who/pull/31
Comment 5 Martin Juhl 2016-02-05 04:26:53 EST
Ok...

Can we get the support included in RHEL????
Comment 6 Radek Novacek 2016-02-09 02:26:41 EST
Martin, adding xenserver support is currently planned for RHEL-7.3.

Note You need to log in before you can comment on or make changes to this bug.