Bug 129223 - last php update, new php-mbstring package/dependency
last php update, new php-mbstring package/dependency
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
ftp://download.fedora.redhat.com/pub/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-05 08:06 EDT by shrek-m
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-05 09:03:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2004-08-05 08:06:13 EDT
Description of problem:
in the last php-update is a php-mbstring - dependency,
php-mbstring was never before in FC1.


Version-Release number of selected component (if applicable):
php-4.3.8-1.1

How reproducible:
Always


Steps to Reproduce:
1. download the php-* updates
2. # rpm -Fvh php-*
3. # rpm -Uvh --aid  php-mbstring-4.3.8-1.1.i386.rpm
Fehler: Failed dependencies:
        php = 4.3.8-1.1 is needed by php-mbstring-4.3.8-1.1    

Actual Results:
# rhn-applet-tui
php                                      4.3.8           1.1
php-mysql                                4.3.8           1.1
php-pgsql                                4.3.8           1.1
php-ldap                                 4.3.8           1.1
php-odbc                                 4.3.8           1.1
php-imap                                 4.3.8           1.1

# rpm -qa php\*
php-4.3.6-1.3
php-pgsql-4.3.6-1.3
php-ldap-4.3.6-1.3
php-mysql-4.3.6-1.3
php-odbc-4.3.6-1.3
php-imap-4.3.6-1.3


# rpm -Fvh php-*
Fehler: Failed dependencies:
        php-mbstring = 4.3.8-1.1 is needed by php-4.3.8-1.1


you have to install php-mbstring with --nodeps before you can freshen
php-* because php-mbstring was never before in FC1


# rhn-applet-tui Ignoring
No package updates are needed.

Expected Results:
if it is really necessary to add a new php-package than
--aid  should solve the dependency ?
Comment 1 Jeff Johnson 2004-08-05 09:03:57 EDT
The --aid option does not upgrade existing packages, will
only add packages that are not already installed.
Comment 2 shrek-m 2004-08-05 10:39:08 EDT
php-mbstring was _surely_ not installed because it was never in the
FC1-release or any previous updates

bye


# pwd
/mnt/sda1/updates/download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386
# ls php-*
php-4.3.4-1.1.i386.rpm           php-mysql-4.3.4-1.1.i386.rpm
php-4.3.6-1.3.i386.rpm           php-mysql-4.3.6-1.3.i386.rpm
php-4.3.8-1.1.i386.rpm           php-mysql-4.3.8-1.1.i386.rpm
php-devel-4.3.4-1.1.i386.rpm     php-odbc-4.3.4-1.1.i386.rpm
php-devel-4.3.6-1.3.i386.rpm     php-odbc-4.3.6-1.3.i386.rpm
php-devel-4.3.8-1.1.i386.rpm     php-odbc-4.3.8-1.1.i386.rpm
php-domxml-4.3.4-1.1.i386.rpm    php-pgsql-4.3.4-1.1.i386.rpm
php-domxml-4.3.6-1.3.i386.rpm    php-pgsql-4.3.6-1.3.i386.rpm
php-domxml-4.3.8-1.1.i386.rpm    php-pgsql-4.3.8-1.1.i386.rpm
php-imap-4.3.4-1.1.i386.rpm      php-snmp-4.3.4-1.1.i386.rpm
php-imap-4.3.6-1.3.i386.rpm      php-snmp-4.3.6-1.3.i386.rpm
php-imap-4.3.8-1.1.i386.rpm      php-snmp-4.3.8-1.1.i386.rpm
php-ldap-4.3.4-1.1.i386.rpm      php-xmlrpc-4.3.4-1.1.i386.rpm
php-ldap-4.3.6-1.3.i386.rpm      php-xmlrpc-4.3.6-1.3.i386.rpm
php-ldap-4.3.8-1.1.i386.rpm      php-xmlrpc-4.3.8-1.1.i386.rpm
php-mbstring-4.3.8-1.1.i386.rpm


# rpm -Fvh --aid php-mbstring-4.3.8-1.1.i386.rpm
#

# rpm -Uvh --aid php-mbstring-4.3.8-1.1.i386.rpm
Fehler: Failed dependencies:
        php = 4.3.8-1.1 is needed by php-mbstring-4.3.8-1.1

# rpm -ivh --aid php-mbstring-4.3.8-1.1.i386.rpm
Fehler: Failed dependencies:
        php = 4.3.8-1.1 is needed by php-mbstring-4.3.8-1.1


# rpm -ivh --nodeps php-mbstring-4.3.8-1.1.i386.rpm
Preparing...               
########################################### [100%]
   1:php-mbstring          
########################################### [100%]


# rpm -Fvh php-*
Preparing...               
########################################### [100%]
   1:php                   
########################################### [ 17%]
   2:php-imap              
########################################### [ 33%]
   3:php-ldap              
########################################### [ 50%]
   4:php-mysql             
########################################### [ 67%]
   5:php-odbc              
########################################### [ 83%]
   6:php-pgsql             
########################################### [100%]

Note You need to log in before you can comment on or make changes to this bug.