Bug 129225 - system-config-soundcard GUI doesn't start without a default soundcard
system-config-soundcard GUI doesn't start without a default soundcard
Status: CLOSED DUPLICATE of bug 125349
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-05 09:09 EDT by Ben Stanley
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Stanley 2004-08-05 09:09:46 EDT
Description of problem: 
Program fails to start GUI 
The following error output is given: 
[root@dragon RPMS]# system-config-soundcard 
Traceback (most recent call last): 
  File 
"/usr/share/system-config-soundcard/system-config-soundcard.py", line 
46, in ? 
    app = soundcard.childWindow() 
  File "/usr/share/system-config-soundcard/soundcard.py", line 160, 
in __init__ 
    self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard())) 
ValueError: list.index(x): x not in list 
 
Version-Release number of selected component (if applicable): 
1.2.8-1 
 
How reproducible: 
I have two soundcards, and no entries in modules.conf to do with 
soundcards, so the default module is always 'None' in 
soundcardBackend.py. This causes a problem with setting the default 
soundcard in soundcard.py 
self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard())) 
I commented out the above line and the tool ran fine for me. I then 
changed it to: 
                if self.soundcardBackend.getDefaultCard() != None: 
                    self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard())) 
This appears to fix my problem.
Comment 1 Bill Nottingham 2004-09-17 17:49:29 EDT

*** This bug has been marked as a duplicate of 125349 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.