This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 129232 - bind-chroot has typo in %post script causing most of %post not to run
bind-chroot has typo in %post script causing most of %post not to run
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-05 10:03 EDT by Max Bowsher
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-09 15:14:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Max Bowsher 2004-08-05 10:03:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040616

Description of problem:
The bind-chroot %post script uses ${prefix} where it should use
%{prefix}   ($ vs. %, shell variable vs. RPM macro).

This is the problem line:
if [ ! -d "${prefix}/var/tmp" ]; then

The intent is to test whether /var/named/chroot/var/tmp exists.
However, because of the typo described above, actually /var/tmp is
checked. This incorrectly does not run a portion of the %post script.


Version-Release number of selected component (if applicable):
bind-chroot-9.2.3-13 (FC2), -18 (FC2.90), and 9.2.4rc6-3 (FC development)

How reproducible:
Always

Steps to Reproduce:
1. rpm -e bind-chroot
2. rm -rf /var/named/chroot
3. rpm -i path/to/bind-chroot-9.2.x-x.i386.rpm
    

Actual Results:
bind-chroot-9.2.3-13 (FC2), -18 (FC2.90):

/var/named/chroot/etc/* are zero-byte files, not copies from /etc
/var/named/chroot/dev/* are zero-byte files, not device nodes.
/var/named/chroot/var/tmp does not exist.
Most of the %post script has not executed.

bind-chroot-9.2.4rc6-3 (FC development):

Due to restructuring of the %post script, the problem is less severe.
/var/named/chroot/var/tmp does not exist.
Comment 1 Jason Vas Dias 2004-08-09 15:14:03 EDT
This is now fixed in bind-chroot-9.2.4rc6-6 .
Comment 2 John Flanagan 2004-12-21 14:49:59 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-567.html

Note You need to log in before you can comment on or make changes to this bug.