Bug 1292397 - Bad BuildRequire to bind99-devel
Bad BuildRequire to bind99-devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All All
unspecified Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 05:22 EST by Lameire Alexis
Modified: 2015-12-18 05:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 05:52:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lameire Alexis 2015-12-17 05:22:36 EST
I had to backport this package into CentOS for use. And when I done this I could see a bad BuildRequire to bind99-devel

instead, this package should BuildRequire to bind-lite-devel.

Moreother, to proper work, two change should be applyed :

First, latest version of bind solve a dirty trick under naming of bind librery and remove "-export" perfix to theses library. So you patch should be updated.

this sed command do the trick :
sed -ie 's|-export||g' dhcp-remove-bind.patch dhcp-sharedlib.patch  dhcp-systemtap.patch dhcp-capability.patch

Second, due to the switch of this library, configure option should be edited :
    --with-libbind=%{_includedir}/bind9 \
    --with-libbind-libs=%{_libdir} \
Comment 1 Tomáš Hozza 2015-12-17 05:52:17 EST
(In reply to Lameire Alexis from comment #0)
> I had to backport this package into CentOS for use. And when I done this I
> could see a bad BuildRequire to bind99-devel

This is not BAD, this is intentional. In Fedora bind version is 9.10.x, which can not be used for building DHCP, therefore there is bind99 package which provides libraries for DHCP from bind 9.9.x version.

> instead, this package should BuildRequire to bind-lite-devel.

t should not. If you rebuild something for CentOS, you should make sure you rebuild all the necessary dependencies.

> Moreother, to proper work, two change should be applyed :
> 
> First, latest version of bind solve a dirty trick under naming of bind
> librery and remove "-export" perfix to theses library. So you patch should
> be updated.
> 
> this sed command do the trick :
> sed -ie 's|-export||g' dhcp-remove-bind.patch dhcp-sharedlib.patch 
> dhcp-systemtap.patch dhcp-capability.patch
> 
> Second, due to the switch of this library, configure option should be edited
> :
>     --with-libbind=%{_includedir}/bind9 \
>     --with-libbind-libs=%{_libdir} \

None of this is relevant for Fedora. Please inspect the git history or changelog of the package to see what happened. Changes in Fedora have their reasons and if you don't rebuild all the necessary dependencies you can not expect the package to work properly.
Comment 2 Lameire Alexis 2015-12-18 05:18:23 EST
I had check the git history and found the proper comment but no real justification was made about the requirement of this dependancy.

So, I suggest you to add in comment bellow the BuildRequire a reference to the discussion that you made earlier on isc mailling [1] list to avoid dunny people like me.

[1] https://lists.isc.org/pipermail/bind-users/2015-February/094636.html

Note You need to log in before you can comment on or make changes to this bug.