Bug 129241 - Add the rest of the Xfce4 core rpms
Add the rest of the Xfce4 core rpms
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-05 10:38 EDT by Matt Thompson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 18:12:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Thompson 2004-08-05 10:38:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.16

Description of problem:
For some reason, Fedora only includes a subset of the core Xfce4 rpms.
 What I mean by that are those programs included by Xfce4 developers
in their tarballs.  I don't mean any of the Xfce-goodies, which are
extras, but those parts included by default.

Looking over current Rawhide, I see these Xfce4-related RPMs:

dbh-1.0.18-4.i386.rpm
dbh-devel-1.0.18-4.i386.rpm
libxfce4mcs-4.0.6-1.i386.rpm
libxfce4mcs-devel-4.0.6-1.i386.rpm
libxfce4util-4.0.6-1.i386.rpm
libxfce4util-devel-4.0.6-1.i386.rpm
libxfcegui4-4.0.6-1.i386.rpm
libxfcegui4-devel-4.0.6-1.i386.rpm
xfce-mcs-manager-4.0.6-1.i386.rpm
xfce-mcs-manager-devel-4.0.6-1.i386.rpm
xfce-mcs-plugins-4.0.6-1.i386.rpm
xfce-utils-4.0.6-1.i386.rpm
xfce4-panel-4.0.6-1.i386.rpm
xfdesktop-4.0.6-1.i386.rpm
xffm-4.0.6-1.i386.rpm
xffm-icons-4.0.6-1.i386.rpm
xfwm4-4.0.6-1.i386.rpm
xfwm4-themes-4.0.6-1.noarch.rpm

Now, compare to Fangorn's FC2 repo
(http://fangorn.new.fr/archives/xfce) which is based on the main
distribution and we see the following omissions from FC:

gtk-xfce-engine-2.1.10-1.i386.rpm
xfcalendar-0.1.9-1.i386.rpm
xfce4-iconbox-4.0.6-1.i386.rpm
xfce4-mixer-4.0.6-1.i386.rpm
xfce4-systray-4.0.6-1.i386.rpm
xfce4-themes-4.0.6-1.noarch.rpm
xfce4-toys-4.0.6-1.i386.rpm
xfce4-trigger-launcher-4.0.6-1.i386.rpm
xfprint-4.0.6-1.i386.rpm

Some of these are pretty important.  Anyone getting help from an Xfce
list or general people will often be referred to "use Iconbox", say. 
Well, with Fedora, that is *not* possible.

If you want a more unified look with GTK 2 programs, you need
gtk-xfce-engine.  If you want to use the ever-more-prevalent
notification-area blips (say gnome-cd or straw), you need xfce4-systray.

Finally, many people prefer to use GUI-style print management.  Well,
with Fedora, since xfprint isn't included, this is *not* possible. 
There actually is a Bugzilla report about this:

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=125788

But since it hasn't been looked at in a couple months, I figured
adding xfprint to this bug wouldn't hurt.

Please, allow a complete Xfce4 to be included in FC3.  I understand
about not including the goodies, and NewRPMs covers those.  But things
like iconbox, systray, gtk-xfce-engine, and xfprint really do need to
be included in the core of an OS.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Create new FC2 box.
2.  Try to use Xfce's iconbox instead of taskbar.
3.
    

Actual Results:  The iconbox should load.

Expected Results:  Can't because the program isn't included by default.

Additional info:
Comment 1 Bill Nottingham 2004-08-05 10:43:48 EDT
Are any of these packaged at fedora.us/Fedora Extras?

That may be a start, but certainly systray seems useful.
Comment 2 Matt Thompson 2004-08-05 10:58:32 EDT
No, they aren't.  The reason I suspect that they aren't at fedora.us
is that Rudolf Kastl of NewRPMs fame used to package Xfce for
RH 9 and then FC 1.  So, I'm guessing fedora.us never had a need to do it.
                                                                     
                                                                      
But, when FC 2 included (part of) Xfce4 in the core, Rudolf decided to
drop the core Xfce4 packages from his repo and only supply
some of the Goodies from:
                                                                     
                                                                      
http://xfce-goodies.berlios.de/
                                                                     
                                                                      
I think there was a sort of perfect confluence of events here.  Many
longtime Xfce4 users never noticed anything wrong when
upgrading to FC2 because Anaconda only installed over the subset. 
Thus, there was still a usable xfce4-systray-4.0.4 from the FC1
days.  Same with iconbox, gtk-xfce-engine, &c.  And new users of Xfce4
adding it fresh would never notice the omission.
                                                                     
                                                                      
It's really only if a Xfce4 user does a fresh install, that they
realise their imported ~/.xfce4 setup goes absolutely nuts because
iconbox is gone, the systray is missing, and everything looks odd due
to the lack of gtk-xfce-engine.
Comment 5 Ngo Than 2004-10-11 18:12:41 EDT
iconbox, systray, gtk-xfce-engine, and xfprint are now included in fc3
test3.

Comment 6 Matt Thompson 2004-10-11 21:45:30 EDT
Did you change the name of gtk-xfce-engine?  I can't find it in my
local mirror's 2.92 directory.
Comment 7 Ngo Than 2004-10-12 04:41:09 EDT
oh sorry, we have made decision to add iconbox, systray, and xfprint
in fc3, but not gtk-xfce-engine.

Note You need to log in before you can comment on or make changes to this bug.