Bug 1292419 - TurboGears2: WSGI: 404 Not found
TurboGears2: WSGI: 404 Not found
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: TurboGears2 (Show other bugs)
23
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul W. Frields
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 06:43 EST by Jan ONDREJ
Modified: 2016-12-20 12:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 12:06:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2015-12-17 06:43:36 EST
Description of problem:
TurboGears2 does not work on Fedora 23 as WSGI server. I use dispatch.wsgi with combination lighttpd. Works well on Fedora 22, but with Fedora 23 I still get 404 Not found error even with root path.

Version-Release number of selected component (if applicable):
TurboGears2-2.3.0-0.4.git6da6959.fc21.noarch

How reproducible:
always

Steps to Reproduce:
Not simple to reproduce, need to set up dispatch.wsgi an an TG2 application, but this is solved by upgrading to new version, so I think no need to reproduce. Tell me if you need reproduce script, I can write one.

Actual results:
Status: 404 Not Found
Pragma: no-cache
Cache-Control: no-cache
Content-Length: 52
Content-Type: text/plain; charset=UTF-8

404 Not Found

The resource could not be found.


Expected results:
Status: 302 Found
Pragma: no-cache
Cache-Control: no-cache
Location: http://delta.salstar.sk:443/w3sa/admin/
Content-Length: 119
Content-Type: text/plain; charset=UTF-8

302 Found


Additional info:
A new version of TurboGears2.3.7 stable can be downloaded from pypi:
  https://pypi.python.org/pypi/TurboGears2
This version fixes this problem, so please update. Why we are using an git/beta version in Fedora and not stable releases, which are available long time?
I know, that it's hard to download them from TG2 website, but are available using pypi, maybe pypi is right place for new release downlaods.

After update also python-crank need to be upgraded to version 7.3, which is already in rawhide, just need to be rebuild.

If you need help with this new package, I have my build and can send you spec file patches.
Comment 1 Jan ONDREJ 2016-04-05 02:21:57 EDT
Is this package still maintained in Fedora? Can I help with updates?
Comment 3 Fedora End Of Life 2016-11-24 09:18:00 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2016-12-20 12:06:31 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.