This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1292445 - Error: Out of sort memory, consider increasing server sort buffer size
Error: Out of sort memory, consider increasing server sort buffer size
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Vu Dinh
Wenjing Zheng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 08:28 EST by Valentas
Modified: 2017-05-31 14:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valentas 2015-12-17 08:28:00 EST
Hi,

OpenShift it's great product! I love it! But I can't use new SilverStripe application version I'm getting "Error: Out of sort memory, consider increasing server sort buffer size".

I suggest to increase the buffer size of mysql: in the my.cnf, sort_buffer_size to 256K.

To allow editing those settings I think best solution is to add new parameter like others ENV[] parameters. Example: max_allowed_packet = <%= ENV['OPENSHIFT_MYSQL_MAX_ALLOWED_PACKET'] ? ENV['OPENSHIFT_MYSQL_MAX_ALLOWED_PACKET'] : '200M' %>
in my.cnf.erb.hidden

Also found old bug report at: https://bugzilla.redhat.com/show_bug.cgi?id=1000167

Maybe you can solve this issue and help me and others who are using OpenShift and SilverStripe.


Best regards.
Comment 1 Vu Dinh 2016-01-27 11:32:25 EST
Hi there,

I have a PR currently in review to be merged to increase the sort buffer size and allow user to change the size via env variable as well. Stay tuned :D.

Thanks for reporting this issue to us.

Vu
Comment 2 openshift-github-bot 2016-01-27 14:46:56 EST
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/3904bed435837c06c8804e874975d8afbe0292da
Bug 1292445: Out of memory error due to insufficient mysql sort buffer size

The new SilverStripe CMS app using php and mysql cartridges fails due to out
of memory on mysql sort buffer which is currently set at 128K.

This commit increases the sort buffer size to 256K and also add the environment
variable OPENSHIFT_MYSQL_SORT_BUFFER_SIZE to allow user to modify the mysql sort
buffer size at their own choices without having modify the my.cnf directly.

Bug 1292445
Link <https://bugzilla.redhat.com/show_bug.cgi?id=1292445>

Signed-off-by: Vu Dinh <vdinh@redhat.com>
Comment 3 Wenjing Zheng 2016-03-07 01:20:54 EST
Verified in devenv_5778, in mysql/conf/my.cnf, sort_buffer_size is 256K now; and it also can be changed like this rhc env-set OPENSHIFT_MYSQL_SORT_BUFFER_SIZE=128K.
Comment 4 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.