Bug 1292466 - [Gtk3.20] Mouse cursor changes only when user clicks to the window
[Gtk3.20] Mouse cursor changes only when user clicks to the window
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 09:25 EST by Martin Stransky
Modified: 2016-01-13 10:45 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 10:45:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Stransky 2015-12-17 09:25:50 EST
Description of problem:
Generally mouse pointer changes when mouse hover over various elements (Text, entry, link...). On Gtk3.19 user needs to click on the element to change cursor. 

nsWindow::SetCursor() seems to be called properly but gdk_window_set_cursor() may not be effective here?

Version-Release number of selected component (if applicable):
gtk3-3.19.5-2.fc24.x86_64
Comment 1 Martin Stransky 2015-12-21 07:11:57 EST
Well, that's because gdk_display_list_seats() in gdk_window_set_cursor() returns null and gdk_window_set_cursor_internal() is not called then. How to fix that?
Comment 2 Martin Stransky 2015-12-21 07:30:12 EST
It may be related:

(firefox:18171): Gdk-CRITICAL **: gdk_seat_get_pointer: assertion 'GDK_IS_SEAT (seat)' failed

(firefox:18171): Gdk-CRITICAL **: gdk_device_get_window_at_position_double: assertion 'GDK_IS_DEVICE (device)' failed
Comment 3 Martin Stransky 2015-12-21 07:31:11 EST
Seems to be also a cause of Bug 1292464.
Comment 4 Martin Stransky 2016-01-13 10:45:06 EST
Fixed now.

Note You need to log in before you can comment on or make changes to this bug.