Bug 1292473 - Error unpacking rpm package python3-requests-2.7.0-7.fc23.noarch
Error unpacking rpm package python3-requests-2.7.0-7.fc23.noarch
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-requests (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Arun S A G
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 09:33 EST by Juan Orti
Modified: 2015-12-17 14:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 14:21:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Orti 2015-12-17 09:33:18 EST
Description of problem:

[root@xenon ~]# LANG=C dnf reinstall python3-requests --allowerasing                                                                                          
Last metadata expiration check performed 1:43:00 ago on Thu Dec 17 13:45:38 2015.
Dependencies resolved.
==============================================================================================================================================================
 Package                                    Arch                             Version                                   Repository                        Size
==============================================================================================================================================================
Reinstalling:
 python3-requests                           noarch                           2.7.0-7.fc23                              fedora                           102 k

Transaction Summary
==============================================================================================================================================================

Total download size: 102 k
Is this ok [y/N]: y
Downloading Packages:
python3-requests-2.7.0-7.fc23.noarch.rpm                                                                                      186 kB/s | 102 kB     00:00    
--------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                          42 kB/s | 102 kB     00:02     
# dnf reinstall python3-requests

Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Reinstalling: python3-requests-2.7.0-7.fc23.noarch                                                                                                      1/2 
Error unpacking rpm package python3-requests-2.7.0-7.fc23.noarch
Error unpacking rpm package python3-requests-2.7.0-7.fc23.noarch
error: unpacking of archive failed on file /usr/lib/python3.4/site-packages/requests/packages/chardet: cpio: rename
  Verifying   : python3-requests-2.7.0-7.fc23.noarch                                                                                                      1/2 
  Verifying   : python3-requests-2.7.0-7.fc23.noarch                                                                                                      2/2 

Reinstalled:
  python3-requests.noarch 2.7.0-7.fc23                                                                                                                        

Complete!



Version-Release number of selected component (if applicable):
python3-requests-2.7.0-7.fc23.noarch
Comment 1 Ralph Bean 2015-12-17 14:12:52 EST
So, whenever you see a 'cpio: rename', it is almost always because your system had someone 'sudo pip install ...' a package before, and now the rpm tools don't know how to deal with those files that they themselves didn't install.

Try removing /usr/lib/python3.4/site-packages/requests* by hand and re-installing.
Comment 2 Juan Orti 2015-12-17 14:21:29 EST
You are right. Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.