Bug 1292474 - long response times very long for case when gluster share used inside OSE pod
long response times very long for case when gluster share used inside OSE pod
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: redhat-storage-server (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Dusmant
storage-qa-internal@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 09:38 EST by Elvir Kuric
Modified: 2016-02-17 19:15 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 02:14:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Ben England 2016-01-04 10:01:32 EST
Why is this a private BZ?

I suspect this isn't limited to containers - I have seen similar things with VMs.

I think it's important to understand the reason that this is a bz.  It's not just that response time is high.  Once system's throughput limit is reached, additional concurrent requests will inevitably increase response time.  The issue could be FAIRNESS - why are some requests taking way longer than other requests?  An unfair system is unusable because response times for some users are unpredictably high.  A fairness metric is described here:

https://en.wikipedia.org/wiki/Fairness_measure

Would be interesting to measure fairness metric for this system, and see whether unusually long response times are confined to particular threads, clients or Gluster subvolumes.

-ben
Comment 5 Shekhar Berry 2016-01-13 02:14:03 EST
Long response time reported by FIO is due to a mistake in post processing script of pbench_fio.

As an example, correct response time is reported here :

http://pbench.perf.lab.eng.bos.redhat.com/results/ose3-master/sb_6pods_8numjobs_1pod_per_node/fio__2015-12-04_08:29:42/2-read-64KiB/reference-result/summary-result.txt

but not here:

http://pbench.perf.lab.eng.bos.redhat.com/results/ose3-master/sb_6pods_8numjobs_1pod_per_node/fio__2015-12-04_08:29:42/2-read-64KiB/reference-result/result.txt

and here:

http://pbench.perf.lab.eng.bos.redhat.com/results/ose3-master/sb_6pods_8numjobs_1pod_per_node/fio__2015-12-04_08:29:42/summary-result.html

Once Andrew fixes the issue with postprocess script, this problem will be fixed. 

Hence closing this ticket.

Note You need to log in before you can comment on or make changes to this bug.