Bug 129254 - [RFE] Allow Update only registrations even if open Management entitlements exist
[RFE] Allow Update only registrations even if open Management entitlements exist
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Fanny Augustin
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-05 11:51 EDT by David Goldberg
Modified: 2007-10-23 22:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 16:00:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Goldberg 2004-08-05 11:51:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1)
Gecko/20040707

Description of problem:
Detail also available in Red Hat support request #351616

I have 6 management entitlements out of about 250 total entitlements
(a mix of ES and WS).  I would like to limit the use of the management
entitlements to a small set of critical systems.  However, not all
those systems are deployed yet.  Since the first six systems
registered (only two of which fit my critical system criteria) got the
management entitlement, and because I cannot down grade an entitlement
on line, I have to remember to remove their profiles and then register
the newly deployed critical system as well as reregister the one whose
profile I removed.  This is unnecessarily painful.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Remove profile from RHN
2.Reregister system
3.Log into RHN see that system has management entitlement
    

Additional info:
Comment 1 David Goldberg 2004-08-06 12:23:44 EDT
I think it's worth noting that there's a bit of additional irony here.
 We only purchased the Basic version of Workstation for which, it
seems, the management module is not even an option.
Comment 2 Mihai Ibanescu 2005-09-30 16:00:17 EDT
Wow this is old.
You can always use a registration key that allows you to specify the entitlement
level. If that is not satisfactory, please feel free to reopen this bug, and we
will consider it as an enhancement request.
Comment 3 David Goldberg 2005-09-30 16:28:05 EDT
(In reply to comment #2)
> Wow this is old.
> You can always use a registration key that allows you to specify the entitlement
> level. If that is not satisfactory, please feel free to reopen this bug, and we
> will consider it as an enhancement request.

Where does one get such a registration key?  We purchased entitlements in bulk.
 Our confirmation of purchase was simply that RHN showed we had X number of
entitlements for each of the versions we subscribed.

But any way, it's now a moot point since we decided not to go with the
management entitlements when we renewed a couple months ago.  However the
inability to downgrade had a bad effect even then.  It was most unpleasant to
discover that instead of downgrading our registered machines, all of our
existing registrations (over 100) were marked unentitled, with no warning
whatsoever in spite that we did renew the Update subscriptions on time.  It was
incredibly irritating to have our users complain that up2date was no longer
working for them and then to log in to RHN see all those gray X's.  Fortunately
I found the entitlement management page and was able to redo them in bulk.

Note You need to log in before you can comment on or make changes to this bug.