Bug 1292693 - [userinterface_public_596]Should not show the "xx was updated" if the resource did not changed actually
[userinterface_public_596]Should not show the "xx was updated" if the resourc...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Padgett
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 00:40 EST by Wei Sun
Modified: 2016-05-12 13:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:08:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2015-12-18 00:40:01 EST
Description of problem:
Tried to edit the resource on web console,but actually,I did not update anything,and just click save button.But the message "xx was updated" still was shown on the page.
If I use `oc edit`,and I do not update anything,the command prompt "Edit cancelled, no changes made."
The console is better to give the similar prompt. 

Version-Release number of selected component (if applicable):
fork_ami_openshift3_userinterface_public_596_157

How reproducible:
Always

Steps to Reproduce:
1.Edit the dc in web console
2.Do not update anything and just click save button
3.

Actual results:
On web page,"xx was updated" is shown.

Expected results:
Should show "Edit cancelled, no changes made" 

Additional info:
Comment 1 Samuel Padgett 2015-12-18 09:08:28 EST
Fix added to https://github.com/openshift/origin/pull/6269
Comment 2 Samuel Padgett 2015-12-18 11:36:07 EST
Moving to ON_QA since fix is in the merge queue.
Comment 3 Wei Sun 2015-12-21 01:35:06 EST
Verified this bug against devenv-rhel7_3004.
Now if I don't update anything,then on the page,I could see "There were no changes to nd to save. Edit cancelled."

Note You need to log in before you can comment on or make changes to this bug.