Bug 1292728 - [Doc] Channel rhel-7-server-optional-rpms is needed for hosted-engine-setup / vdsm installation
[Doc] Channel rhel-7-server-optional-rpms is needed for hosted-engine-setup /...
Status: CLOSED DUPLICATE of bug 1290873
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.5.6
All Linux
high Severity high
: ---
: ---
Assigned To: rhev-docs@redhat.com
rhev-docs@redhat.com
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 03:27 EST by Martin Tessun
Modified: 2015-12-22 07:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 07:07:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Tessun 2015-12-18 03:27:10 EST
Description of problem:
The documentation of RHEV 3.5 states to enable the following channels:
# subscription-manager repos --enable=rhel-7-server-rpms
# subscription-manager repos --enable=rhel-7-server-supplementary-rpms
# subscription-manager repos --enable=rhel-7-server-rhev-mgmt-agent-rpms
(Taken from https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5/html/Installation_Guide/Subscribing_to_the_Required_Entitlements.html)

But indeed also the optional channel is required:
# subscription-manager repos --enable=rhel-7-server-optional-rpms

Version-Release number of selected component (if applicable):
Current RHEV 3.5 Documentation

How reproducible:
Always

Steps to Reproduce:
1. Subscribe only to the channels listed in the documentation:
   # subscription-manager repos --enable=rhel-7-server-rpms
   # subscription-manager repos --enable=rhel-7-server-supplementary-rpms
   # subscription-manager repos --enable=rhel-7-server-rhev-mgmt-agent-rpms
2. Try installing ovirt-hosted-engine-setup as described in Docs:
   # yum upgrade
   # yum install ovirt-hosted-engine-setup

Actual results:
The installation will fail with broken dependencies.
After subscribing to optional channel as well, the installation succeeeds.

Expected results:
Following the documentation the installation should work.


Additional info:
Please add the necessary optional channel to the Documentation, so please modify:

# subscription-manager repos --enable=rhel-7-server-rpms
# subscription-manager repos --enable=rhel-7-server-supplementary-rpms
# subscription-manager repos --enable=rhel-7-server-rhev-mgmt-agent-rpms

to:

# subscription-manager repos --enable=rhel-7-server-rpms
# subscription-manager repos --enable=rhel-7-server-supplementary-rpms
# subscription-manager repos --enable=rhel-7-server-rhev-mgmt-agent-rpms
# subscription-manager repos --enable=rhel-7-server-optional-rpms
Comment 1 Yaniv Lavi 2015-12-22 07:07:21 EST

*** This bug has been marked as a duplicate of bug 1290873 ***

Note You need to log in before you can comment on or make changes to this bug.