Bug 1292763 - Getting "Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Invalid parameter provider on Vcsrepo" while using puppet providers with multiple environments on satellite 6.1
Getting "Error: Could not retrieve catalog from remote server: Error 400 on S...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Configuration Management (Show other bugs)
6.1.1
All Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 04:59 EST by Komal
Modified: 2016-11-30 07:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-30 07:44:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2097591 None None None 2015-12-18 05:01 EST

  None (edit)
Description Komal 2015-12-18 04:59:00 EST
Description of problem: Getting error as "Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Invalid parameter provider on Vcsrepo" while using puppet providers with multiple environments on satellite 6.1

A bug exists in Puppet that causes issues when attempting to use modules that make use of custom providers in combination with multiple environments:

 https://tickets.puppetlabs.com/browse/PUP-1515

This bug manifests itself prominently in Satellite, due to the extensive use of environments through Content Views.

A manifest with the following code (using vcsrepo) triggers this issue:

  vcsrepo { '/opt/git/hosdep-scripts':
    ensure   => latest,
    provider => git,
    require  => [ Package["git"], File["/opt/git/ssh/id_rsa"] ],
    source   => 'git@eicilll009:hosdep.test.git',
    identity => '/opt/git/ssh/id_rsa'
  }

with the following output on a puppet run:

# puppet agent -t -v
Info: Retrieving plugin
Info: Loading facts in /var/lib/puppet/lib/facter/staging_http_get.rb
Info: Loading facts in /var/lib/puppet/lib/facter/ip6tables_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/apt_reboot_required.rb
Info: Loading facts in /var/lib/puppet/lib/facter/service_provider.rb
Info: Loading facts in /var/lib/puppet/lib/facter/mysql_server_id.rb
Info: Loading facts in /var/lib/puppet/lib/facter/staging_windir.rb
Info: Loading facts in /var/lib/puppet/lib/facter/apt_update_last_success.rb
Info: Loading facts in /var/lib/puppet/lib/facter/facter_dot_d.rb
Info: Loading facts in /var/lib/puppet/lib/facter/root_home.rb
Info: Loading facts in /var/lib/puppet/lib/facter/apt_updates.rb
Info: Loading facts in /var/lib/puppet/lib/facter/package_provider.rb
Info: Loading facts in /var/lib/puppet/lib/facter/puppet_vardir.rb
Info: Loading facts in /var/lib/puppet/lib/facter/rh_certificates.rb
Info: Loading facts in /var/lib/puppet/lib/facter/pe_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/iptables_persistent_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/haproxy_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/iptables_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/puppetgem.rb
Info: Loading facts in /var/lib/puppet/lib/facter/concat_basedir.rb
Info: Loading facts in /var/lib/puppet/lib/facter/rsyslog_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/gemhome.rb
Info: Loading facts in /var/lib/puppet/lib/facter/mysql_version.rb
Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Invalid parameter provider on Vcsrepo[/opt/git/hosdep-scripts] at /etc/puppet/environments/KT_European_Parliament_Lab_RHEL7_x86_64_2/modules/ep_base/manifests/ep_gitclone.pp:29 on node rhlinux02.ep.parl.union.eu
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

The work around on this issue is manually applying the patch proposed here:

 https://github.com/puppetlabs/puppet/pull/2963/files

This change works well for specific use case. This fix will be included in Puppet 3.7.5 according to the bugreport. 

Can we consider backporting it ?


Version-Release number of selected component (if applicable):
Satellite 6.1

How reproducible:
Always

Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:


Additional info:
Comment 4 Bryan Kearney 2016-07-26 11:25:24 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 5 Bryan Kearney 2016-07-26 11:37:46 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 7 Ohad Levy 2016-11-30 07:44:13 EST
Satellite 6.2 delivered puppet 3.8.z in which this issue is resolved.

Note You need to log in before you can comment on or make changes to this bug.