Bug 1292770 - preserve audit in bootloader
preserve audit in bootloader
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 05:10 EST by Terje Røsten
Modified: 2015-12-21 16:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 16:41:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terje Røsten 2015-12-18 05:10:36 EST
Description of problem:

Due to audit spamming: 
 https://bugzilla.redhat.com/show_bug.cgi?id=1227379

I need audit=0 on kernel cmdline, however anaconda don't preserve this setting
if set on kernel cmdline on kickstart install.

Fix:

add audit to global_preserve_args in pyanaconda/bootloader.py:


diff --git a/pyanaconda/bootloader.py b/pyanaconda/bootloader.py
index 63130f8..44cdd3c 100644
--- a/pyanaconda/bootloader.py
+++ b/pyanaconda/bootloader.py
@@ -236,7 +236,7 @@ class BootLoader(object):
                             "noht", "acpi", "video", "pci", "nodmraid",
                             "nompath", "nomodeset", "noiswmd", "fips",
                             "selinux", "biosdevname", "ipv6.disable",
-                            "net.ifnames"]
+                            "net.ifnames", "audit"]
     preserve_args = []
 
     _trusted_boot = False
Comment 1 Brian Lane 2015-12-21 16:41:21 EST
bootloader --append="audit=0" should handle this for you.

https://github.com/rhinstaller/pykickstart/blob/master/docs/kickstart-docs.rst#bootloader

Note You need to log in before you can comment on or make changes to this bug.