This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 129286 - desktop-file-install fails to remove last Category
desktop-file-install fails to remove last Category
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: desktop-file-utils (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-05 18:05 EDT by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 11:20:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2004-08-05 18:05:22 EDT
Note: I've reported this upstream to xdg-list, but got no responses
there about where to report desktop-file-utils bugs, so I'll try my
luck here.

Even in the latest (upstream) CVS HEAD of desktop-file-utils,
"desktop-file-install --remove-category ..." fails to remove the last
category.

Reproducer using the emacs desktop entry from FC2:

  $ cd /tmp
  $ grep Categories /usr/share/applications/gnu-emacs.desktop
  Categories=TextEditor;Development;X-Red-Hat-Base;Application;
  $ desktop-file-install --vendor foo --dir $PWD \
    --remove-category Application \
    /usr/share/applications/gnu-emacs.desktop &>/dev/null
  $ grep Categories ./foo-gnu-emacs.desktop
  Categories=TextEditor;Development;X-Red-Hat-Base;Application;

Expected:

  Categories=TextEditor;Development;X-Red-Hat-Base;
Comment 1 Ray Strode [halfline] 2005-08-31 11:20:53 EDT
Hi Ville,

This problem seems to be fixed now.  I'm going to close the bug.
Comment 2 Ville Skyttä 2005-08-31 11:28:03 EDT
Indeed, thanks. 

Note You need to log in before you can comment on or make changes to this bug.