Bug 129287 - 500 error for systems if mon_admin user is not org_admin.
Summary: 500 error for systems if mon_admin user is not org_admin.
Status: CLOSED DUPLICATE of bug 129291
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kim Dykeman
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-05 22:09 UTC by Kim Dykeman
Modified: 2007-06-20 20:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kim Dykeman 2004-08-05 22:09:44 UTC
Description of problem:

A Monitoring admin can view a list of user's notification methods.
This list has links to Users and notification methods; however, the
ability to view/edit these is currently restricted to org_admins so
clicking on either of these links results in a 500 if the monitoring
admin is not an org_admin. 

Version-Release number of selected component (if applicable):

3.15

How reproducible:

Always

Steps to Reproduce:
1. As a monitoring admin that is not also an org admin, click on the
top-level monitoring tab.

2. Click on the link for a system or a probe that the user doesn't
have permission for.

Actual results:

500 Error.

Expected results:

One would expect to arrive at the system details page or the probe
details page.

Additional info:

Comment 1 Kim Dykeman 2004-08-05 22:27:34 UTC
I'm closing this one since I intermixed the description of two
seperate bugs.  I opened the following bugs in it's stead:

bug 129291
bug 129292



*** This bug has been marked as a duplicate of 129291 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:04:58 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.