Bug 1292885 - Unresponsive Black screen of creating a guided tree!
Unresponsive Black screen of creating a guided tree!
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: manstis
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 11:06 EST by Olivier
Modified: 2016-02-17 11:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 11:22:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error, consolelog and .niogit (795.43 KB, application/zip)
2015-12-18 11:06 EST, Olivier
no flags Details
Settings.xml file as requested (11.82 KB, application/xml)
2016-01-05 13:45 EST, Olivier
no flags Details

  None (edit)
Description Olivier 2015-12-18 11:06:20 EST
Created attachment 1107217 [details]
screenshot of error, consolelog and .niogit

Description of problem: After the creation of a guided tree rule, I got the error: "Unable to complete you request.The following exception occurs: null"


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 manstis 2016-01-04 06:41:18 EST
Can you please provide steps to reproduce?

I tried using the provided .niogit folder with Business Central but it contains numerous Organizational Units, Repositories and Projects. Which should I use to re-create the problem? I also had a quick look through the various OUs, Repositories and Projects but did not see any Data Object definitions nor any Project dependencies to JARs containing POJOS. I found a "TestDecTree" in OrgUnit1/ordrepo1/FirstProj. This opened OK, but since the Project contains no Data Objects or dependencies to JARs containing POJO's it's impossible to "author" a tree.
Comment 3 Olivier 2016-01-04 09:15:43 EST
I was using the "Process" Organizational Unit, "language" repository and the "LanguageProject" project. When I attempted to create a guided decision tree I got the error in the screenshot, then a black screen, further attempts only gave me the error.
Comment 4 manstis 2016-01-05 08:11:19 EST
Hi, I tried with jboss-bpmsuite-6.2.0.GA-deployable-eap6.x.

I installed a fresh EAP6.4, deployed the above WAR and cloned the niogit/language repository. I could see the "Workflow" and "LanguageProject" and browsing the latter see packages, Data Objects, Decision Table and Decision Tree. All opened OK. I then tried creating a new Decision Tree and this too worked without problem. 

Have I missed something, are there additional steps I need follow?

With kind regards,

Mike
Comment 5 Olivier 2016-01-05 08:54:17 EST
These were the correct steps, is there a problem on my end then? I tried again creating a guided decision tree, I was greeted with the same error before and after creation.
Comment 6 manstis 2016-01-05 09:03:56 EST
Thanks for clarifying Oliver.

Could you be so kind, please, to repeat from a fresh install and document each step you perform; up to the point of failure? A copy of your settings.xml could be helpful too (I saw some errors in the original log relating to deployment of Projects to a RedHat internal repository configured in <distributionManagement> but this should not cause the problem you encounter).

Thanks.
Comment 7 Olivier 2016-01-05 13:45 EST
Created attachment 1111923 [details]
Settings.xml file as requested
Comment 8 Olivier 2016-01-05 13:49:16 EST
I have attached the settings.xml file. I started from scratch, created a new Org Unit, a new repo and project, tried to create a new guided decision tree and it worked as expected! I'm not quite sure what caused the problem on my first try. It just said in the Messages section "Parameter named 'value' should be not null!" without providing a file name.
Comment 9 manstis 2016-02-09 09:49:08 EST
Olivier, can we close this BZ, it seems the issue (self-)resolved?
Comment 10 Olivier 2016-02-17 11:21:33 EST
Yes this can be closed!

Note You need to log in before you can comment on or make changes to this bug.