Bug 1293004 - Test case failure: Outputs - VGA on GF108M [NVS 5400M] [10de:0def] (Lenovo T430 dedicated graphics)
Test case failure: Outputs - VGA on GF108M [NVS 5400M] [10de:0def] (Lenovo T4...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-nouveau (Show other bugs)
7.2
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Ben Skeggs
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 20:52 EST by Vasiliy Sharapov
Modified: 2016-04-27 01:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-27 01:09:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (61.94 KB, text/plain)
2015-12-18 20:52 EST, Vasiliy Sharapov
no flags Details

  None (edit)
Description Vasiliy Sharapov 2015-12-18 20:52:12 EST
Created attachment 1107561 [details]
/var/log/Xorg.0.log

Filed from caserun (https://tcms.engineering.redhat.com/run/260139/#caserun_10820700)

Version-Release number of selected component (if applicable):
RHEL-7.2-20150820.0
xorg-x11-server-Xorg-1.17.2-9.el7.x86_64
xorg-x11-drv-nouveau-1.0.11-1.el7.x86_64
kernel-3.10.0-306.0.1.el7.x86_64
kernel-3.10.0-322.el7.x86_64
linux-firmware-20150904-43.git6ebf5d5.el7.noarch
mesa-dri-drivers-10.6.5-3.20150824.el7.x86_64
Steps to Reproduce: 
obtain a box with VGA output (laptop)


 1. connect screen through VGA port
 2. perform suspend/resume cycle two times



Actual results: 
Hot-un-plugging is undetected. Must run xrandr or something to get the output removed.

Expected results:
Screens should be correctly set, their native resolution should be set and
suspend/resume cycles should work as well
Comment 2 Ben Skeggs 2016-04-27 01:09:13 EDT
This is not a bug, but the expected behaviour (on VGA outputs only).  It's not possible to detect the unplug without polling, and polling VGA status will cause display flicker.

Note You need to log in before you can comment on or make changes to this bug.