Bug 1293070 - [abrt] kscreenlocker: qt_message_fatal(): kscreenlocker_greet killed by SIGABRT
[abrt] kscreenlocker: qt_message_fatal(): kscreenlocker_greet killed by SIGABRT
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kscreenlocker (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Vrátil
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:75650138689a04e38d4c9f186e4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-19 15:53 EST by Nick
Modified: 2016-02-23 09:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 09:06:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (48.30 KB, text/plain)
2015-12-19 15:53 EST, Nick
no flags Details
File: cgroup (190 bytes, text/plain)
2015-12-19 15:53 EST, Nick
no flags Details
File: core_backtrace (7.75 KB, text/plain)
2015-12-19 15:53 EST, Nick
no flags Details
File: dso_list (17.20 KB, text/plain)
2015-12-19 15:53 EST, Nick
no flags Details
File: environ (1.43 KB, text/plain)
2015-12-19 15:53 EST, Nick
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-19 15:53 EST, Nick
no flags Details
File: maps (81.73 KB, text/plain)
2015-12-19 15:53 EST, Nick
no flags Details
File: mountinfo (3.21 KB, text/plain)
2015-12-19 15:53 EST, Nick
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-19 15:53 EST, Nick
no flags Details
File: open_fds (131 bytes, text/plain)
2015-12-19 15:53 EST, Nick
no flags Details
File: proc_pid_status (1019 bytes, text/plain)
2015-12-19 15:53 EST, Nick
no flags Details
File: var_log_messages (28 bytes, text/plain)
2015-12-19 15:53 EST, Nick
no flags Details

  None (edit)
Description Nick 2015-12-19 15:53:29 EST
Description of problem:
Screen saver auto-locked after 5 minutes while I was working on another computer.  Came back to unlock, and got a message telling me I needed to use: loginctl unlock-sessions from another terminal.  That was weird. This is a fresh installation as of a couple of hours ago, so it's up to date.  I have no idea why this happened. 

There are two potential things:

1) the system was under heavy IO load, copying ~136GB of files from one SATA disk to another at the time.
2) I had just installed the proprietary Nvidia driver, but hadn't restarted yet.

Version-Release number of selected component:
kscreenlocker-5.5.0-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/libexec/kscreenlocker_greet --graceTime 5000 --ksldfd 44
crash_function: qt_message_fatal
executable:     /usr/libexec/kscreenlocker_greet
global_pid:     17454
kernel:         4.2.7-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #5 qt_message_fatal at global/qlogging.cpp:1578
 #6 QMessageLogger::fatal at global/qlogging.cpp:781
 #7 QSGRenderLoop::handleContextCreationFailure at /usr/src/debug/qtdeclarative-opensource-src-5.5.1/src/quick/scenegraph/qsgrenderloop.cpp:244
 #8 QSGThreadedRenderLoop::handleExposure at /usr/src/debug/qtdeclarative-opensource-src-5.5.1/src/quick/scenegraph/qsgthreadedrenderloop.cpp:919
 #9 QSGThreadedRenderLoop::exposureChanged at /usr/src/debug/qtdeclarative-opensource-src-5.5.1/src/quick/scenegraph/qsgthreadedrenderloop.cpp:857
 #10 QWindow::event at kernel/qwindow.cpp:2053
 #11 QQuickWindow::event at /usr/src/debug/qtdeclarative-opensource-src-5.5.1/src/quick/items/qquickwindow.cpp:1413
 #12 QCoreApplication::notify at kernel/qcoreapplication.cpp:1038
 #13 QCoreApplication::notifyInternal at kernel/qcoreapplication.cpp:965
 #14 QCoreApplication::sendSpontaneousEvent at ../../src/corelib/kernel/qcoreapplication.h:227
Comment 1 Nick 2015-12-19 15:53:34 EST
Created attachment 1107817 [details]
File: backtrace
Comment 2 Nick 2015-12-19 15:53:34 EST
Created attachment 1107818 [details]
File: cgroup
Comment 3 Nick 2015-12-19 15:53:36 EST
Created attachment 1107819 [details]
File: core_backtrace
Comment 4 Nick 2015-12-19 15:53:37 EST
Created attachment 1107820 [details]
File: dso_list
Comment 5 Nick 2015-12-19 15:53:38 EST
Created attachment 1107821 [details]
File: environ
Comment 6 Nick 2015-12-19 15:53:38 EST
Created attachment 1107822 [details]
File: limits
Comment 7 Nick 2015-12-19 15:53:40 EST
Created attachment 1107823 [details]
File: maps
Comment 8 Nick 2015-12-19 15:53:41 EST
Created attachment 1107824 [details]
File: mountinfo
Comment 9 Nick 2015-12-19 15:53:42 EST
Created attachment 1107825 [details]
File: namespaces
Comment 10 Nick 2015-12-19 15:53:43 EST
Created attachment 1107826 [details]
File: open_fds
Comment 11 Nick 2015-12-19 15:53:44 EST
Created attachment 1107827 [details]
File: proc_pid_status
Comment 12 Nick 2015-12-19 15:53:45 EST
Created attachment 1107828 [details]
File: var_log_messages
Comment 13 Rex Dieter 2016-02-23 09:06:51 EST
OK, most likely opengl wasn't working due to inconsistent video driver state

Note You need to log in before you can comment on or make changes to this bug.